Download it now!
Bug 67501 - CONFIGURATION: Wrong implementation to handle cell borders.
Summary: CONFIGURATION: Wrong implementation to handle cell borders.
Status: RESOLVED DUPLICATE of bug 34449
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-29 19:50 UTC by tilus06
Modified: 2013-08-05 05:55 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Picture showing what is the problem and how should it looks like. (138.91 KB, image/png)
2013-07-29 19:50 UTC, tilus06
Details
Maybe this picture shows the solution. (81.89 KB, image/png)
2013-08-02 19:58 UTC, tilus06
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tilus06 2013-07-29 19:50:26 UTC
Created attachment 83238 [details]
Picture showing what is the problem and how should it looks like.

Problem description:
There is not enough space to display neighbouring cell's differently formatted borders, so it is unnecessary that every cell has 4 unique borders. For example: F3 has black bottom border, and F4 has yellow top border. All you will see is a yellow border between F3 and F4. There is only one border between neighbouring cells, so if I set black bottom border for F3, it means I set black top border for F4 too. That is their common attribution. But if you see F3's border settings, it says it has its own border settings. It cause problems. For example: Let's say there is 3x3 neighbouring cells (B3-D5) with black borders. You want to set the (C4) middle cell's 4 borders' colour to yellow, and LibreOffice will display only 2 yellow borders, not 4, although if you check, it knows it has 4 yellow borders. I think the border should be a common attribution for neighbouring cells as in Microsoft Office.

Steps to reproduce:
1. Set 4 black border for each one: B3, B4, B5, C3, C4, C5, D3, D4, D5
2. Set 4 yellow border for C4

Current behavior:
C4 has 4 yellow borders, but LibreOffice display 2 yellow and 2 black borders.

Expected behavior:
Because C4 has 4 yellow borders, LibreOffice should display 4 yellow borders.
Operating System: All
Version: 4.0.2.2 release
Comment 1 afonit 2013-08-02 02:21:50 UTC
Digging into this,
I do see the results you have posted.
Although after playing with it, this is what I have observed:
format > cells > borders
the default is:
width = 0.05 pt

     PointA
however, hit the up arrow once and:
width = 0.30 pt
and the issue goes away - you do see the yellow on all four of the cell's borders.

     PointB
additionally, if you change the width to be:
width = 9.00 pt (the maximum allowed)
you will observe that the yellow borders are there, but now you also see the black borders of the bordering cells. (again using your example).

So, given PointA above, there certainly IS AN ISSUE WITH THE DEFAULT WIDTH of 0.05 pt for the cell border - as it does give the effect you have observed, however just increasing the border slightly gives the expected results.
Comment 2 tilus06 2013-08-02 19:55:15 UTC
(In reply to comment #1)

I studied this behavior, and the problem is not the border width, but your PointA helped me to find out what is it.

So the problem: Every cell has its own borders, and the neighbouring borders are placed on each other. So if you set 2 kind of width, in general, the thicker will be displayed.

My suggestion for solution: The border of neighbouring cells should be a common attribution. For example: L2's bottom border is L3's top border. I think this is how Excel works, so Calc should works like this. I upload an attachment to illustrate some options.
Comment 3 tilus06 2013-08-02 19:58:16 UTC
Created attachment 83552 [details]
Maybe this picture shows the solution.
Comment 4 Florian Reisinger 2013-08-05 05:55:22 UTC

*** This bug has been marked as a duplicate of bug 34449 ***