Bug Hunting Session
Bug 67529 - [gtk] draw/impress have dark document background with some dark themes
Summary: [gtk] draw/impress have dark document background with some dark themes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-30 10:25 UTC by Emilio Pozuelo Monfort
Modified: 2014-11-02 20:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
draw (72.81 KB, image/png)
2013-07-30 10:26 UTC, Emilio Pozuelo Monfort
Details
impress (101.24 KB, image/png)
2013-07-30 10:26 UTC, Emilio Pozuelo Monfort
Details
writer (57.77 KB, image/png)
2013-07-30 10:27 UTC, Emilio Pozuelo Monfort
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emilio Pozuelo Monfort 2013-07-30 10:25:38 UTC
LO Draw and Impress have a dark document on dark background when using a dark gtk2 theme (e.g. Adwaita-Dark from http://gnome-look.org/content/show.php/?content=148170) and having the libreoffice-gtk integration installed.

They should have a white document on dark background as Writer does.

See the attached screenshots.

This is with LO 4.0.3 and 4.1.0.4.
Comment 1 Emilio Pozuelo Monfort 2013-07-30 10:26:18 UTC
Created attachment 83283 [details]
draw
Comment 2 Emilio Pozuelo Monfort 2013-07-30 10:26:43 UTC
Created attachment 83284 [details]
impress
Comment 3 Emilio Pozuelo Monfort 2013-07-30 10:27:18 UTC
Created attachment 83285 [details]
writer
Comment 4 Emilio Pozuelo Monfort 2013-07-30 11:40:23 UTC
As pointed out on irc, this looks similar to bug #35365. That bug apparently fixed this for (at least) Writer and Impress, so looks like Impress/Draw have regressed.
Comment 5 Björn Michaelsen 2013-07-30 12:07:36 UTC
If this is indeed a regression:
a/ It should be marked as such in keywords
b/ It should be bibisected https://wiki.documentfoundation.org/Bibisect
c/ or at least the first version showing the regression should be specified
Comment 6 Emilio Pozuelo Monfort 2013-07-30 13:47:01 UTC
Sure, it's just that I only think it's a regression because bug #35365 talked about fixing it. I haven't checked if that was actually the case, but I'd look into it.
Comment 7 Emilio Pozuelo Monfort 2013-07-30 15:06:45 UTC
All of Writer, Impress and Draw have a dark background on 3.5.4 (1:3.5.4+dfsg2-0+deb7u2) and 3.6.5 (1:3.6.5-1), which is not surprising as the fix in bug #35365 only landed after 3.6.5.

Got 3.6.7 .debs from libreoffice.org, and all of Writer, Impress and Draw have a white document background.

So it looks like Draw and Impress have regressed at some point after 3.6.7. I'll try to narrow down when the regression happened.
Comment 8 Emilio Pozuelo Monfort 2013-07-30 16:37:49 UTC
So turns out I was wrong on the above. Things work fine with Adwaita-Dark, but don't work with another theme I have which is darker.

What is really happening is that, depending on the background color set in the gtk2 theme, Draw/Impress will draw a dark background or a white one.

E.g.

Install the Adwaita-Dark theme linked above, set your gtk theme to Adwaita-Dark
See that LO Draw/Impress have a white document background
Modify /usr/share/theme/Adwaita-Dark/gtk-2.0/gtkrc, change bg_color from #363b3b to #111215
Fail

This is because of Tools > Options > Accessibility "Automatically detect high contrast mode of the system". If I uncheck that, Draw and Impress get a normal white background.
Comment 9 Emilio Pozuelo Monfort 2013-07-31 08:53:20 UTC
So summarizing:

- LO tries to guess if the theme is high-contrast (and sometimes makes a mistake)
- Impress and Draw's document background get a dark color for some dark themes (apparently when LO thinks they are high contrast). This doesn't happen with Writer or Calc (they always have a white document background / white table).

-> There should be some consistency here. Either all programs follow the theme and have a dark background, or all of them have a white background. I lean for the latter: it doesn't make sense for Draw to display a non-white background; likewise for Impress.
Comment 10 ign_christian 2014-07-02 14:15:38 UTC
Hi Emilio.. Does it solved in LO 4.2.5.2 or 4.3.0.1? 

If no please change status back to UNCONFIRMED, otherwise RESOLVED WORKSFORME