Bug Hunting Session
Bug 67558 - Experimental Sidebar enabled: Sporadic crashes when closing LibO
Summary: Experimental Sidebar enabled: Sporadic crashes when closing LibO
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar
  Show dependency treegraph
 
Reported: 2013-07-30 19:28 UTC by OfficeUser
Modified: 2014-02-18 08:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot (Windows) (9.30 KB, image/png)
2013-07-30 19:29 UTC, OfficeUser
Details
screen shot (Linux) (50.37 KB, image/png)
2013-07-30 19:58 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2013-07-30 19:28:47 UTC
This happens from time to time when closing LibreOffice after working
with the experimental Sidebar enabled.

See attached Windows screen shot.

I will ad a Linux screen shot of similar crash as soon as I see it again.

In total I have seen the problem about 5 to 10 times.
Comment 1 OfficeUser 2013-07-30 19:29:26 UTC
Created attachment 83323 [details]
screen shot (Windows)
Comment 2 OfficeUser 2013-07-30 19:58:55 UTC
Created attachment 83329 [details]
screen shot (Linux)

Added screen shot Linux.
Comment 3 Jorendc 2013-08-03 09:50:09 UTC
Hi,

Thanks for reporting!

I'm using the sidebar for quite a time too, and can not confirm these crashes on Windows 8, Mac OSX 10.8.4 and Linux Mint 15 x64. So it might be interesting to have a backtrace. Although you don't have a special build to do backtraces, it'll reveal hopefully some helpful information what goes wrong. Please see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace

After doing that, please attach the backtrace log to the bug report.

Thanks for your time to make LibreOffice a better product!
Joren
Comment 4 OfficeUser 2013-08-04 18:55:24 UTC
I have installed LibreOffice manually with the deb package provided on the LibreOffice homepage.

If I install "libreoffice-dbg" from the Ubuntu repositories doesn't it install an old LibreOffice out of the Ubuntu repositories?
Comment 5 OfficeUser 2013-08-25 23:25:13 UTC
Seems to be fixed in
Version: 4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903

==> CLosing.
Comment 6 OfficeUser 2013-08-28 13:57:41 UTC
REOPENED.

Version 4.1.1.2 is still affected.
Comment 7 OfficeUser 2013-09-03 07:09:56 UTC
Additional information:

Both reported crashes from Linux and windows are from totally different machines. So it cannot really be related to special environment.
Comment 8 Maxim Monastirsky 2014-01-07 19:32:10 UTC
Setting back to NEEDINFO, since the requested (in comment 3) information not provided.
Comment 9 tommy27 2014-01-08 21:22:57 UTC
I suggest retesting with 4.1.4.2

moreover is the crash just specific to Writer, Calc or to all LibO suite applications?
Comment 10 tommy27 2014-01-09 19:57:32 UTC
please, specify exactly the O/S versions you reproduce the bug (i.e WinXp, Win7, 32 or 64bit etc. etc)
Comment 11 OfficeUser 2014-02-11 19:23:23 UTC
At the moment it looks like Version 4.2.0.4 is not affected. I will watch it.

I will close the bug in about one or two weeks if I cannot see this crash anymore. If the problem persists I will provide you more information.
Comment 12 OfficeUser 2014-02-18 08:02:05 UTC
Cannot reproduce anymore with Version 4.2.0.4.

==> Closing.