Bug Hunting Session
Bug 67565 - FORMATTING: Formattings (esp. fonts) not retained after saving a document
Summary: FORMATTING: Formattings (esp. fonts) not retained after saving a document
Status: RESOLVED DUPLICATE of bug 67665
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-31 03:36 UTC by Markus Michels
Modified: 2013-08-13 17:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Impress doc to show the problem of lost font information in styles (14.08 KB, application/vnd.oasis.opendocument.presentation)
2013-07-31 09:53 UTC, Markus Michels
Details
opd - changed (16.35 KB, application/vnd.oasis.opendocument.presentation)
2013-07-31 10:25 UTC, Cor Nouws
Details
Drawing demonstrating lost font information in styles (32.08 KB, application/vnd.oasis.opendocument.graphics)
2013-08-13 16:11 UTC, Graham Bartlett
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Michels 2013-07-31 03:36:07 UTC
Problem description: 

Using customized templates for impress (color coding, styles, fonts, etc). Since 4.1.0.4 some formatting gets lost after saving and re-opening the file.

Steps to reproduce:
1. Create empty impress document
2. Create a custom style
3. Assign a custom and easily recognizable font
4. Add some boxes with text to the page
5. Apply custom style to boxes (they now look as defined in your custom style)
6. Save document
7. Re-open the document
8. Fonts in boxes is no longer the same as desired
9. Checking the style unveils that the font information in the defined and applied style has changed

Current behavior:

See above

Expected behavior:

LO should keep the style information.

I must say that since LO 4 there are some serious issues with the style and formatting management in the software. I renders unusable unfortunately, which makes me sad, since otherwise I do admire and promote LO privately and at work. But I cannot continue that way. This functionality is basic stuff that should work across all versions like charm...

Anyway, thanks in advance for taking care of this,

Markus
Operating System: Debian
Version: 4.1.0.4 release
Last worked in: 4.0.4.2 release
Comment 1 Markus Michels 2013-07-31 05:42:46 UTC
I managed to further nail down this unwanted behavior.

The loss of style information applies...

... to font settings (color and others seem to be okay) - in my case custom fonts revert back to Times New Roman which I am not using at all...
... if styles (or style trees) are NOT linked to the built-in top-level style "Default"

It is sad because the template I use has a large customized style tree that is NOT linked to Default, therefore all of my presentation now get corrupted when I save them.

Rebuilding this style tree for any presentation I am using or that does exist somewhere is simply not possible. I hope this gets addressed ASAP.
Comment 2 Markus Michels 2013-07-31 06:43:15 UTC
Just realize that renaming an existing style also is not retained after save and re-open of a document. The old name simply appears again. As assumed earlier I guess the entire formatting and style management section seems to have some serious issues, and it is a core component in an office suite...
Comment 3 Derek Keats 2013-07-31 06:53:20 UTC
I am getting exactly this on LO 4.1.04 on Ubuntu GNU/Linux 13.04. It appears as if the styles are not being saved. Making hard changes to the fonts of individual items works, but not changes to styles. Style changes only last for the current session, but are reverted when the file is closed and reopened. This is a killer bug for anyone doing lots of presentations.
Comment 4 Cor Nouws 2013-07-31 08:20:58 UTC
Hi Markus, 

Thanks for reporting. But ...
are you sure you have the 4.1.0.4 from the LibreOffice website?
The problem you describe was fidex in 4.1.0.3 and it works perfect for me in the 4.1.0.4

Best,
Cor
Comment 5 Markus Michels 2013-07-31 09:10:31 UTC
Cor,


thanks for this info. I am using 4.1.0.4 from the Launchpad PPA built for raring from the LibreOffice packaging team (ppa:libreoffice/ppa).

It surprises me that this has a fundamentally different behavior... I will check later today or tomorrow the version off the website and report back.

Thanks for your help,

Markus
Comment 6 Markus Michels 2013-07-31 09:35:30 UTC
Cor,


it seems I get exactly the same problem with version 4.1.0.4 off the website.

Also: just realize I cannot even delete custom styles anymore... Very strange...

Thanks for your commitment and stamina,


Markus
Comment 7 Cor Nouws 2013-07-31 09:43:07 UTC
(In reply to comment #6)
 
> it seems I get exactly the same problem with version 4.1.0.4 off the website.

Can you then pls provide a test file?
thanks!
Comment 8 Markus Michels 2013-07-31 09:53:23 UTC
Created attachment 83352 [details]
Impress doc to show the problem of lost font information in styles

see my comment
Comment 9 Markus Michels 2013-07-31 09:56:07 UTC
Document with three styles in use

"default"
"inline dudu" (dependent on "default")
"outlin dudu" (standalone root style)

Changed fonts in "default" and "outline dudu" to source sans pro. Fonts in boxes change accordingly. Also "inline dudu" inherits and displays the font properly.

Then save, close and re-open. Now all three styles show times new roman as font. Also the style definitions show times new roman.

Thanks for your help,


Markus
Comment 10 Cor Nouws 2013-07-31 10:25:03 UTC
Created attachment 83354 [details]
opd - changed

I changed the original attachment in 4.1.0.4

When I open that again, the changes I made simply are there.

So there is something odd here..?
Comment 11 Markus Michels 2013-07-31 15:37:12 UTC
When I open the doc you posted it is in colorful variants of "times new roman". Did you define another font type? If so then I lost the setting upon opening the file on my machine.

It seems that changes in color and size of a font are properly retained, just the font type isn't.

Best,


Markus
Comment 12 Jon 2013-08-05 10:41:26 UTC
Comment on attachment 83352 [details]
Impress doc to show the problem of lost font information in styles

I'm having what appears to be the same problem in both Impress and Draw, on Windows 7.
-Happens only when creating text boxes with the text tool.
-Does not happen if I create and assign a new style after styling the text in the text box. In other words, the default style changes after saving and closing, but not custom styles.
Comment 13 Cor Nouws 2013-08-06 21:04:17 UTC
(In reply to comment #12)

> ... In other words, the default style changes after saving and
> closing, but not custom styles.

Looks as if _this_ is confirmed by
  https://bugs.freedesktop.org/show_bug.cgi?id=67665#c2
Comment 14 Markus Michels 2013-08-07 16:35:43 UTC
Just wanted to add that deleting custom styles does not work right now. Maybe this helps to track down the root cause of this misery.

It is really a BIG issue for me because all my documents are built based on a customized set of styles. So I cannot make any changes or additions to existing documents right now because they get crippled style-wise when saving the changes. I need to consider switching back to evil powerpoint unfortunately...

Best regards,


Markus
Comment 15 Mike 2013-08-08 21:18:55 UTC
Seeing the same problem of lost font settings (i.e. font reverting to Times New Roman after save and reopen) with Impress version 4.1.0.4 from ppa:libreoffice/ppa .

My primary difference is that font settings are lost also for the root graphics style "Default". Highly annoying and makes Impress pretty much unusable for editing any presentation.

This defect should have much higher priority since it is very basic functionality that is completely broken.
Comment 16 Derek Keats 2013-08-09 08:00:41 UTC
Does anyone know of a way to work around this? It is a major productivity killer. Is there any patch released or anything? I will cut off my leg to pay at this stage.
Comment 17 Cor Nouws 2013-08-09 08:59:10 UTC
Indeed it is a nasty bug. Pls remeber we are still in the early stage of the 4.1-series.
It's alwas easy to have a 4.0.4 or so installed parallel.


Further I expect that bug 67665 - marked as MAB - will have enough attention to get it fixed soon.
Maybe one of you is willing to check if that is exactly the same as this issue?
thanks,
Cor
Comment 18 Derek Keats 2013-08-09 16:07:26 UTC
I would love to help in any way I can, but that other bug you mention is in Windows and I don't use Windows. This bug is killing me. Unfortunately, there are also nasty bugs in 4.0.4, and I went to 4.1 hoping for improvements.
Comment 19 Markus Michels 2013-08-10 06:23:34 UTC
I just switched to Apache OpenOffice 4.0.0 which has been released recently and will stay until the many issues associated with formatting (fonts not retained, page copy yielding loss of custom formats, cannot delete custom formats, negative indents not saved, ...) are resolved. It seems that these issues had all been introduced with the LO 4 series. I do not know the technical background but maybe they are interconnected somehow? Would it be okay to suggest to have a look at the AOO4 code in that regard?

Thanks and regards,


Markus
Comment 20 Graham Bartlett 2013-08-13 16:11:16 UTC
Created attachment 84020 [details]
Drawing demonstrating lost font information in styles
Comment 21 Graham Bartlett 2013-08-13 16:12:11 UTC
I have the same problem, using v4.1.0.4 on Windows.

Steps to reproduce problem:-

- Open attached document.
- On first page of attached document, right-click on top-left text box with text "Force feedback input" and select "Edit style".
- Change the font to Arial.
- Watch all text in Times font change to Arial.
- Save document.
- Close document.
- Open document.
- Look in horror as all text is back to Times again!!!!!
Comment 22 Graham Bartlett 2013-08-13 16:15:12 UTC
PS. Raised severity.  Honestly, if styles aren't saved then this renders the entire package unuseable by almost anyone for almost anything.
Comment 23 Cor Nouws 2013-08-13 17:45:45 UTC
As suggested before: I think it's best to set this as a duplicate of bug 67665

*** This bug has been marked as a duplicate of bug 67665 ***