Bug 67632 - LO does not export EPS graphics embedded in an ODT document when directly exporting PDF
Summary: LO does not export EPS graphics embedded in an ODT document when directly exp...
Status: RESOLVED DUPLICATE of bug 64161
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-01 16:53 UTC by kurt.pfeifle
Modified: 2013-08-02 15:23 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
ODT file exposing the bug described here (104.74 KB, application/vnd.oasis.opendocument.text)
2013-08-01 16:53 UTC, kurt.pfeifle
Details
PDF file created by LO via direct PDF export (240.16 KB, application/pdf)
2013-08-01 16:57 UTC, kurt.pfeifle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kurt.pfeifle 2013-08-01 16:53:48 UTC
Created attachment 83456 [details]
ODT file exposing the bug described here

## (see also: "LO also cannot display the EPS graphics in a stable way while in document editing mode")

Attached ODT document was created using LibreOffice 4.1.0.4 on a Mac OS X Mountain Lion.

It uses an embedded EPS graphic and a PNG graphic (both looking identical). There are two problems with LO's handling of EPS graphics, the first one of which is addressed by this bug report (the other one is a separate bug report, here mentioned in passing only).

      1. When exporting the ODT to PDF, the EPS graphic never shows up, 
         and it is never embedded in the PDF. Instead, there is only 
         same red textual metadata printed in the frame where the EPS 
         should be.
         
      2. (The EPS displays fine in document editing mode after a new start
         of LO, and it also shows up in print preview. But after a while 
         LO turns sour: from then onwards LO only displays the same red 
         text as it puts into PDF exports -- both in document editing mode
         as well as in print preview.)

The PNG graphic is always exported to PDF correctly. (PNG graphics also never switch to a b0rken display like EPS graphics do.)

When creating a PDF via one of the many "Print to PDF" alternatives (which go through a detour, using PostScript as an intermediate format), the EPS graphic shows up correctly in the final PDF.

This bug may or may not be a duplicate of "LO cannot display the EPS graphics in a stable way while in document editing mode".

I don't know whether LO on Windows or LO on Linux handles EPS without these faults.
Comment 1 kurt.pfeifle 2013-08-01 16:57:59 UTC
Created attachment 83457 [details]
PDF file created by LO via direct PDF export

This PDF had the "Embed Open Document file" option enabled when exported from LibreOffice
Comment 2 kurt.pfeifle 2013-08-01 17:09:49 UTC
See also bug #67634 which I reported against the graphics stack component. (This one is reported against the "printing and PDF export" component -- not sure if both these my choices were correct.)
Comment 3 Thomas van der Meulen 2013-08-01 17:34:35 UTC

*** This bug has been marked as a duplicate of bug 64161 ***