Bug 67670 - Change default value for spacing on Columns tab to be more than 0
Summary: Change default value for spacing on Columns tab to be more than 0
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium trivial
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Page-Layout-Columns Writer-UX
  Show dependency treegraph
 
Reported: 2013-08-02 13:29 UTC by Pablo AB
Modified: 2018-01-23 21:21 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pablo AB 2013-08-02 13:29:29 UTC
A very annoying bug for me is that just as it comes LibreOffice, on Format > "Page..." > Columns, the "Spacing" between columns is by default "0.00cm", the two (or more) columns with no space between them! By default MS Office is "1,25 cm". It could be for example the half of the left page margin.
BTW, at least in Spanish (not sure if apply to English) should be a space between the number and the symbol "cm" (like in, "0.50 cm").
Comment 1 Cor Nouws 2013-08-02 13:48:06 UTC
Thanks for your report Pablo.
Looks as a useful idea to me.

- Set to New.
- Version to olders LibreOffice (has been as it is now ever since the beginning)
- Little update fr summary.

(By the way: how simple it looks, it could be more complicated in the code because filters _may_ use the existing defaults. I'm not sure. Just a note.)
Cheers,
Cor
Comment 2 Pablo AB 2015-04-13 14:23:03 UTC
I was trying to come back to life this bug, maybe just creating a simple patch, but is not an easy task just only finding the code where this value is set... It's a pity, a LibreOffice developer could resolve this in 5'...
Comment 3 Cor Nouws 2015-04-13 14:28:55 UTC
(In reply to Pablo AB from comment #2)
> I was trying to come back to life this bug, maybe just creating a simple
> patch, but is not an easy task just only finding the code where this value
> is set... It's a pity, a LibreOffice developer could resolve this in 5'...

Hi Pablo,

For sure if you have set the initial steps for development - downloading source and making a build (see https://wiki.documentfoundation.org/Development)  - ask your question on IRC or the developers list and for sure someone will be glad to give you the proper pointers. Great if you can look at this!
Cor
Comment 4 tommy27 2016-04-16 07:25:02 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-05-22 13:26:24 UTC Comment hidden (obsolete)
Comment 6 Pablo AB 2017-05-22 13:59:59 UTC
I'm using Ubuntu 16.04 and the updated current version is LibreOffice 5.1.6.2.

The problem is there, here is a screenshot: http://i.imgur.com/vYaUmDP.png

I'm using LibreOffice since more than 10 years (hen OpenOffice) and Im pretty sure this issue was there from the beginning of times.

The funny thing is that for someone how knows this is a trivial bug, maybe just changing 0 to 5 mm on a XML of default values...
Comment 7 Thomas Lendo 2017-10-08 23:17:18 UTC
Adding keyword needsUXeval to get comments from UX team to find a better default value.
Comment 8 Yousuf Philips (jay) 2017-10-09 17:29:42 UTC
We recently discussed this at a meeting a checked the default columns spacing from other competing word processors and came to a conclusion about it.

@Heiko: what was the concluded amount we agreed on?
Comment 9 Heiko Tietze 2017-10-15 20:15:57 UTC
https://design.blog.documentfoundation.org/2017/09/26/default-margins-users-apply-libreoffice-writer/

We didn't ask about column gap but 0.5cm sounds like a good solution for A4 (used by Scribus, Latex does 10pt by default).
Comment 10 Yousuf Philips (jay) 2017-10-15 22:46:16 UTC
Here are the defaults from competing word processors

Calligra - 0.6cm (0.24")
TextMaker - 0.24"
WPS - 0.75cm (0.3")
Word 2010 - 0.5"
Wordperfect - 0.5"
Comment 11 Heiko Tietze 2017-10-27 18:37:24 UTC
We decided in the design team to go with 0.5cm as default for column spacing.
Comment 12 Commit Notification 2017-10-31 09:36:48 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=420452e56c2f18b85e6a59dbba80c06d96e28abd

tdf#67670 Change default column spacing to 0.5cm

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Yannick.D 2017-11-28 09:24:56 UTC
Does this setting extend to sections as well? I‘m not on a pre release build to test. Expected behavior would be using the same value as for a global two column layout.

Steps to check:

- Create a new document in Writer.
- Insert > Section…
- Tab Columns > Set it to two

=> should use spacing of 0.5cm between them
Comment 14 Heiko Tietze 2017-11-28 09:31:02 UTC
(In reply to Yannick.D from comment #13)
> Does this setting extend to sections as well?

Yes, the default for spacing between columns in sections is now 0.5cm (or the equivalent depending on chosen unit).
Comment 15 Severo Raz 2018-01-23 21:21:40 UTC
(In reply to Pablo AB from comment #0)
> BTW, at least in Spanish (not sure if apply to English) should be a space
> between the number and the symbol "cm" (like in, "0.50 cm").

True, it is so established by the SI. However, if you see it without a space in your interface it may be due to a locale issue. I see "0,50 cm" on my end.