Download it now!
Bug 67675 - Other: Libreoffice reports corrupt file when opening file on network smb share
Summary: Other: Libreoffice reports corrupt file when opening file on network smb share
Status: RESOLVED DUPLICATE of bug 67527
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Javaz
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-08-02 15:36 UTC by Alex
Modified: 2013-12-15 22:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
I odt file is corrupt, please how to fix it (2.35 MB, application/vnd.oasis.opendocument.text)
2013-12-09 16:05 UTC, Javaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2013-08-02 15:36:34 UTC
Problem description: Libreoffice reports corrupt file when opening file on network smb share.  Was able to open files across network before last update.

Steps to reproduce:
1. Select file on network share with nautilus via double-click

Current behavior:
Presents dialog box stating ...
"The file 'VisibleProductsCatalog2013.odt' is corrupt and therefore cannot be opened. LibreOffice can try to repair the file.

The corruption could be the result of document manipulation or of structural document damage due to data transmission.

We recommend that you do not trust the content of the repaired document.
Execution of macros is disabled for this document.

Should LibreOffice repair the file?"

Click on "No" and get the following dialog:

"The file 'VisibleProductsCatalog2013.odt' could not be repaired and therefore cannot be opened."

The presentation of these 2 dialog boxes occurs 3 times, then it presents a text import dialog.

If the file is copied to a local directory, it will open properly.

Expected behavior:
File to open with Libreoffice.

Operating System: Ubuntu
Version: 4.1.0.4 release
Last worked in: 4.0.4.2 release
Comment 1 piviul 2013-08-05 09:41:07 UTC
The same happens to  me. The problem doesn't arise downgrading to 4.0.4.

Piviul
Comment 2 sandhrine 2013-08-06 11:18:38 UTC
I get the same error using Samba protocol. ODT files are on a QNAP local server. This not occured on the 4.0.4 version.
Comment 3 vivAce 2013-08-07 07:12:55 UTC
Might this bug be similar to Bug 67769?  https://bugs.freedesktop.org/show_bug.cgi?id=67769
Comment 4 vivAce 2013-08-07 07:14:08 UTC
And Bug 67527?
Comment 5 Maxim Monastirsky 2013-08-08 11:16:59 UTC

*** This bug has been marked as a duplicate of bug 67527 ***
Comment 6 Javaz 2013-12-09 16:05:43 UTC
Created attachment 90520 [details]
I odt file is corrupt, please how to fix it

I odt file is corrupt, please how to fix it