Bug 67680 - Impossible to search for text attributes with VoiceOver
Summary: Impossible to search for text attributes with VoiceOver
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Boris Dušek
URL:
Whiteboard: target:4.2.0 target:4.1.2
Keywords:
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2013-08-02 18:06 UTC by Boris Dušek
Modified: 2013-08-20 13:35 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Boris Dušek 2013-08-02 18:06:26 UTC
When there is a text with parts of it in e.g. bold, the user cannot search for the bold text using VO-Cmd-B. Same for italics, underlined etc.
Comment 1 Boris Dušek 2013-08-02 18:08:32 UTC
Just adding that is the case even with Change-Id I21a633af0bf426759f639435581fcd3bfeafa598 applied.
Comment 2 Boris Dušek 2013-08-08 18:37:19 UTC
I posted on Apple's accessibility mailing list since I have not been able to track down the cause in reasonable amount of time. Here is a link to the post: http://prod.lists.apple.com/archives/accessibility-dev/2013/Aug/msg00005.html
Comment 3 Boris Dušek 2013-08-09 18:41:07 UTC
https://gerrit.libreoffice.org/#/c/5334/
Comment 4 Commit Notification 2013-08-10 14:57:41 UTC
Boris Dušek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9c8831244062202e9066b97be7082e72e1194866

fdo#67680: Impossible to search for text attributes with VoiceOver



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-08-20 13:35:56 UTC
Boris Dušek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=788d11aee3b59bb8428beae231d85f0c7d0235ce&h=libreoffice-4-1

fdo#67680: Impossible to search for text attributes with VoiceOver


It will be available in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.