Bug Hunting Session
Bug 67761 - FILESAVE: Saving in doc format created additional blank line
Summary: FILESAVE: Saving in doc format created additional blank line
Status: RESOLVED DUPLICATE of bug 66165
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-05 03:04 UTC by bugquestcontri
Modified: 2013-08-05 11:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test kit with explanations in each file (85.33 KB, application/zip)
2013-08-05 03:04 UTC, bugquestcontri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-08-05 03:04:45 UTC
Created attachment 83638 [details]
Test kit with explanations in each file

Problem description: 
When saving a Wrtier file, containing an email address and URL in seperate lines without any additional text in both lines, in doc-format and opening this file again in Writer, for each saving in doc-format and opening in Writer cycle an additional blank line is added below the email address line and the url line.

Above Is valid for the file in which I first observed the bug. Due to confidentialiyt reasons I cannot submit the file with the orginal content. However, the files TestAddtionalLinesAfterEmail&URL_08. odt and doc are the original file with the confidential content removed or modified. Removal of condifidencial content did not influence the behavior of this file. All modification and observation explanations are given in these files. 

TestAddtionalLinesAfterEmail&URL_08. odt and doc are based on an ott-file which was most like created early April 2013 and the that time latest version of 3.6 family

I tried to repeat the same effect in a new Writer based on my default template created in 4.0.4

I recommend to read first the odt-version of each test file attached because opening of the the doc-files is expected to increase the number of blank lines

Steps to reproduce:


1 – open a new Writer file
2 – type an email address in first line and second line an URL 
(The content of the 3 rd line could be a blank line as the last line in the document, or a blank line between a text line, or a text line as the last line: text linie is default style)
3- save as doc-file (and odt-file for comparision)
4- open in doc file in writer => there is an additional blank line below the email address
=> there is an additional blank line below the email address but not below the URL.  This is not consistent with the very first observation documented and visible in estAddtionalLinesAfterEmail&URL_08. odt and doc


Test kit contains

TestAddtionalLinesAfterEmail&URL_08.doc / odt : original file when bug was first observed. Based on 3.6 ott file

30805_AdditionalLinesAfterSavingInDoc_0x.odt / doc  
a blank line after the URL from the beginning

30805_AdditionalLinesAfterSavingInDoc&DefaultTextLine_0x.odt / doc 
a text line in default style directly below the URL 

30805_AdditionalLinesAfterSavingInDoc&DefaultTextLine&BlankLineBeforeDefaultTextLine_0x.odt / doc 
a blank line between the URl line and a text line


There are questions in AskLibO to this topic
http://ask.libreoffice.org/en/question/21094/every-time-i-open-one-document-in-libre-office-blank-lines-have-been-added/?comment=21099#comment-21099

http://ask.libreoffice.org/en/question/20698/why-does-space-manual-line-break-leave-a-blank-line/

Expected behavior:
No addtitional blank lines when saving in doc format.
Operating System: Windows XP
Version: 4.0.4.2 release
Comment 1 Cor Nouws 2013-08-05 06:48:12 UTC
Hi,  I expect this is a duplicate of bug 64989

*** This bug has been marked as a duplicate of bug 64989 ***
Comment 2 Cor Nouws 2013-08-05 06:49:15 UTC
Sory, better is duplicate of 66165 - fixed in 4.0.5!

*** This bug has been marked as a duplicate of bug 66165 ***
Comment 3 bugquestcontri 2013-08-05 11:10:39 UTC
This is good news in terms of the solution we will soon have and bad news because it took me some time today......
I take the good news!!!