Bug 64989 - FILE SAVE: A newline /paragraph is added after pictures (anchored as character) and fields, when saved as .doc
Summary: FILE SAVE: A newline /paragraph is added after pictures (anchored as charact...
Status: RESOLVED DUPLICATE of bug 66165
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: compatibility
Keywords: regression
: 65080 65104 65538 65540 65950 66375 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-05-25 22:13 UTC by Etienne Hirt
Modified: 2013-08-05 06:48 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
odt file that remains stable (20.94 KB, application/vnd.oasis.opendocument.text)
2013-05-26 10:50 UTC, Etienne Hirt
Details
doc file that has a newline after picture (20.50 KB, application/msword)
2013-05-26 10:56 UTC, Etienne Hirt
Details
odt file that ads newlines in footer after total_pages, after filnename and again after the graphics (36.20 KB, application/vnd.oasis.opendocument.text)
2013-05-27 20:15 UTC, Etienne Hirt
Details
Three Screenshots (1.58 MB, image/jpeg)
2013-06-09 19:42 UTC, hurstrd198
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Etienne Hirt 2013-05-25 22:13:34 UTC
In 4.0.2 everything worked fine. In 4.0.3.3 suddenly a newline is added after each picture. Resulting in a separation of the picture and caption after every save and reopen.
Comment 1 Etienne Hirt 2013-05-25 22:15:40 UTC
Running Lubuntu 12.04 64Bit
Comment 2 Etienne Hirt 2013-05-25 22:16:31 UTC
Sorry again:
Running Lubuntu 12.10 64Bit
Comment 3 Cor Nouws 2013-05-26 10:38:18 UTC
Hi Etienne,
thanks for the report. Can you pls attach a test document?
regards,
Cor
Comment 4 Etienne Hirt 2013-05-26 10:50:51 UTC
Created attachment 79798 [details]
odt file that remains stable
Comment 5 Etienne Hirt 2013-05-26 10:56:01 UTC
Created attachment 79799 [details]
doc file that has a newline after picture

It seems that this bug might only be triggered if the picture was set to "in line with text" at the wrapping setting of MS Word. This is the LO setting "as character" for the anchor
Comment 6 Cor Nouws 2013-05-26 11:04:34 UTC
thanks Etienne.
I can partly confirm:

- open .odt in 4.0.3
- save as .doc
- open .doc again: extra line is added

- open .odt in 4.0.2
- save as .doc
- open .doc again: extra line is nót added

however... when I open the .doc that you attached in 4.0.2, I see the extra line too...
Comment 7 Etienne Hirt 2013-05-26 11:33:40 UTC
Dear Cor,

thanks for checking.

I understood that the newline is added when saving in 4.0.3. The attached doc was already saved in 4.0.3, thus has this newline already in the file.
Comment 8 Cor Nouws 2013-05-26 15:02:01 UTC
thanks again!
set some values for the bug
Comment 9 Etienne Hirt 2013-05-27 20:15:23 UTC
Created attachment 79867 [details]
odt file that ads newlines in footer after total_pages, after filnename and again after the graphics

The newline not only is added after a graphics, but also after some fields such as:
* total pages?
* filename

This can be reproduced when saving the Newline_in_Footer as .doc
Comment 10 Michael Meeks 2013-05-28 09:13:46 UTC
Miklos - IIRC you and/or Cedric were looking at something like this ? :-)
Comment 11 Cor Nouws 2013-05-28 14:09:32 UTC
*** Bug 65080 has been marked as a duplicate of this bug. ***
Comment 12 Cor Nouws 2013-05-29 05:15:08 UTC
*** Bug 65104 has been marked as a duplicate of this bug. ***
Comment 13 Piotr 2013-05-30 17:59:48 UTC
I also confirm. LO 4.0.3 on Windows. It is very annoying when each time I open the document I must delete extra new lines multiplying all the time after filesave! I encountered problems with pictures and footers. When You close/open the document several times the footer becomes half a page size.... I set high priority because it always destroys the document.
Comment 14 Linus Drumbler 2013-05-31 17:11:47 UTC
This isn't just when saving as a .doc file; it applies to .odt as well.
Comment 15 David 2013-06-07 17:29:40 UTC
(In reply to comment #13)
> I also confirm. LO 4.0.3 on Windows. It is very annoying when each time I
> open the document I must delete extra new lines multiplying all the time
> after filesave! I encountered problems with pictures and footers. When You
> close/open the document several times the footer becomes half a page
> size.... I set high priority because it always destroys the document.


I have same problem as Piotr with footers, at least when saving in .doc format.
Comment 16 Piotr 2013-06-08 04:03:59 UTC
David - It's not about the footer but new line is created after fields. Since You probably have <page number> field in your footer it is so.

I also noticed that some work around is possible because it happens mostly when field is the last character. So try to enter some character after page number for example "- page number -" and maybe it will help.
Comment 17 Cor Nouws 2013-06-08 11:48:47 UTC
*** Bug 65538 has been marked as a duplicate of this bug. ***
Comment 18 Cor Nouws 2013-06-08 19:39:19 UTC
*** Bug 65540 has been marked as a duplicate of this bug. ***
Comment 19 hurstrd198 2013-06-09 19:42:12 UTC
Created attachment 80583 [details]
Three Screenshots
Comment 20 hurstrd198 2013-06-09 20:02:32 UTC
If a footnote is placed at the end of a paragraph and the document is saved as a Microsoft Word 97/2000/XP/2003 document, and the document is then opened, a new empty paragraph has been inserted after the footnote.  If this document is saved as a .doc again, then another empty paragraph is inserted.  See previously attached jpg "Three Screenshots."

This does not happen when the document is saved as an ODF Text Document (.odt).

My only work-around is to insert some spaces after the footnote number in the body of the text, and then select those spaces and do:  Format: Character: Position: Normal.
Comment 21 David 2013-06-13 17:59:40 UTC
(In reply to comment #16)
> David - It's not about the footer but new line is created after fields.
> Since You probably have <page number> field in your footer it is so.
> 
> I also noticed that some work around is possible because it happens mostly
> when field is the last character. So try to enter some character after page
> number for example "- page number -" and maybe it will help.

Thank you Piotr.  I tried your workaround and it works perfectly.  Obviously not ideal, but it will help alot until this bug is fixed.
Comment 22 Kevin Suo 2013-06-21 04:01:37 UTC
*** Bug 65950 has been marked as a duplicate of this bug. ***
Comment 23 Cor Nouws 2013-06-29 21:54:54 UTC
*** Bug 66375 has been marked as a duplicate of this bug. ***
Comment 24 Michael Stahl (CIB) 2013-07-01 20:05:29 UTC

*** This bug has been marked as a duplicate of bug 66165 ***
Comment 25 Cor Nouws 2013-08-05 06:48:12 UTC
*** Bug 67761 has been marked as a duplicate of this bug. ***