Download it now!
Bug 67814 - Chinese proportional fonts missing and can't be rendered
Summary: Chinese proportional fonts missing and can't be rendered
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2013-08-06 07:41 UTC by Selwyn Tang
Modified: 2015-07-30 15:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Chinese proportional font missing in 4.1.0.4 Writer (122.74 KB, image/png)
2013-08-06 07:41 UTC, Selwyn Tang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Selwyn Tang 2013-08-06 07:41:01 UTC
Created attachment 83697 [details]
Chinese proportional font missing in 4.1.0.4 Writer

Upon upgrading from 4.0.4.2 to 4.1.0.4, those Chinese proportional fonts are missing from the font selection pull-down menus, and texts in old documents using those fonts are not rendered correctly.

Some Chinese fonts are provided in both monospaced and proportional variants in one .ttc file.

In my case, the font in questions are the DFHeiLight-B5 "華康細黑體" and the DFPHeiLight-B5 "華康細黑體(P)", where the "(P)" denotes the proportional variant.

On the left-hand side of the screenshot (4.0.4.2), both monospaced (without "(P)" in the font name) and proportional (with "(P)" in font name) variants are available together.

On the right-hand side (4.1.0.4), the proportional variant is missing, and the selected font name is shown in italics, meaning it is missing and being substituted.
Comment 1 Selwyn Tang 2013-08-06 07:44:04 UTC
Fixed screenshot: http://i.imgur.com/xDmmWKn.png
Comment 2 Yuki Kawara 2013-08-29 16:06:21 UTC
Same problem here with Microsoft's Meiryo fonts, which are distributed in .ttc (true type collection)

I thought that the support of ttcfonts has been trashed, but Cambria & Cambria Math (included in cambria.ttc) both show, as well as most Japanese .ttc.
Comment 3 Selwyn Tang 2014-02-05 11:18:48 UTC
The problem seems fixed in 4.2.0.4.
Comment 4 Kevin Suo 2015-01-12 14:21:24 UTC
(In reply to Selwyn Tang from comment #3)
Please confirm whether this issue still exists in the latest version (4.3.5.2 or the test version 4.4.0.2).
If it works, please mark as RESOLVED WORKSFORME. Otherwise, set back to NEW.
Comment 5 QA Administrators 2015-07-18 17:35:28 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-07-18
Comment 6 Selwyn Tang 2015-07-30 15:46:15 UTC
It's fixed since at least 4.3.0.4. Thanks!