Bug Hunting Session
Bug 67827 - Other: Storing fails at backup copy - fatally on cifs folder
Summary: Other: Storing fails at backup copy - fatally on cifs folder
Status: RESOLVED DUPLICATE of bug 55004
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-06 13:18 UTC by Uwe Dippel
Modified: 2013-08-13 05:11 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Dippel 2013-08-06 13:18:13 UTC
Problem description: 

Having backups activated, I can only store a file once. For the next 'Save', it will complain "error creating object. could not create backup copy".

Steps to reproduce:
1. Create a new any-LO-file
2. Save it as TFile
3. Save it again

Current behavior:
It does not save; the message as above pops up.

Expected behavior:
A proper 'save' and a proper .bak

Analysis:
I am storing on a cifs-mounted share. Any new target file name works well. Any 'save' does not. The .bak is created on the local drive, but somehow it fails and results with a zero size. Then, the 'Save' process is abandoned and my edits are nowhere stored. (The first time, however, the .bak is created properly. Only later does it fail.)

Two or three bugs/RFEs here: First, of course, it needs to work. But secondly, I consider it wrong to stall the 'Save' because the backup fails earlier. If the backup fails, for whatever reason, the normal 'Save' still needs to go through. A failure at backup must not abandon the proper 'Save'-procedure. 

              
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 Maxim Monastirsky 2013-08-13 05:11:40 UTC

*** This bug has been marked as a duplicate of bug 55004 ***