Bug Hunting Session
Bug 67885 - FILESAVE: Files locked after saved on network drive
Summary: FILESAVE: Files locked after saved on network drive
Status: RESOLVED DUPLICATE of bug 67534
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-08-08 06:18 UTC by Mark.Rodehorst
Modified: 2013-10-25 10:36 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
error message (14.31 KB, image/png)
2013-08-08 06:18 UTC, Mark.Rodehorst
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark.Rodehorst 2013-08-08 06:18:37 UTC
Created attachment 83807 [details]
error message

Problem description: When a file is saved on a network drive and you want to open it again short time after it's saved, you get a message "File is locked by unknown user".
you can open it as copy or write protected or cancel

After like 30 seconde or a minute the write protection is removed and u can work with it again.

Steps to reproduce:
1. open a file on a network drive
2. save and close
3. reopen the same file

Current behavior:
file locked message

Expected behavior:
opening the file without writeprotection
              
Operating System: Windows 7
Version: 4.1.0.4 release
Last worked in: 4.0.0.3 release
Comment 1 Maxim Monastirsky 2013-08-19 15:23:59 UTC
Reproducible under Windows 7 with LO 4.1.1.1. 

@Mark.Rodehorst: Unlike what you said, you don't need to save the document before reopening, just open-close-open. Can you confirm that?
Comment 2 Maxim Monastirsky 2013-08-19 15:29:43 UTC
Changing 'Component' field, since it affects other LO modules too (tried with Writer & Impress).
Comment 3 Mark.Rodehorst 2013-08-23 07:41:10 UTC
yes, i can edit something and close the file with saving then.
Same behaviour - file is locked.
if i reopen it as a copy i can overwrite the original file with the copy without any problems.
Comment 4 Don't use this account, use tml@iki.fi 2013-08-23 10:49:36 UTC
What kind of network drive is it? A Windows server, normal Windows (what version?), Linux, something else like a NAS, or something even more exotic like a WebDAV server mapped as a drive letter or whatnot?
Comment 5 Don't use this account, use tml@iki.fi 2013-08-23 11:05:15 UTC
Also the type of document might affect the behaviour, so what is it? .odt, .doc, .xlsx, etc?
Comment 6 Maxim Monastirsky 2013-08-23 11:50:57 UTC
@Tor Lillqvist: My confirmation (comment 1) is about OpenDocument files. The share is a simple share on Windows 7 client.
Comment 7 Jared 2013-08-23 22:59:41 UTC
I am also receiving this issue.  I have a network drive shared (D-Link DNS-323 NAS device shared with SMB protocol) and Windows clients have had trouble .

I can confirm this with the 4.1.1.1 build on Windows 7.

Downgrading to 4.0.5 fixed the problem for me, for now.

I made some notes here: https://bugs.freedesktop.org/show_bug.cgi?id=66518

Mounting with cifs on Linux seems to not raise the same issue for me.
Comment 8 Jared 2013-08-23 23:00:46 UTC
(In reply to comment #5)
> Also the type of document might affect the behaviour, so what is it? .odt,
> .doc, .xlsx, etc?

The formats we've seen are ods and odt.
Comment 9 Robert Popa 2013-08-31 19:52:15 UTC
Hello!

In 4.0.5 and 4.1.1 release there is the same behaviour on 64bit and 32bit, Win 77 Home and Professional machines:

If I open a file from a network drive, make modifications and click save then the file is not saved with mess: Error saving the document XXXX.ods:
Access to P:\_Documente personale\Membrii familiei\copiii 2.ods was denied that there are no sufficient rights.

The same behaviour is with quick start on and off.

For me this is a showstopper, as I cannot use anymore neither 4.0.5 nor 4.1.1. Reverting back to 4.0.4 where this did not happen.
Comment 10 Robert Popa 2013-08-31 19:53:23 UTC
https://bugs.freedesktop.org/show_bug.cgi?id=68082 is a similar bug, but not the same!
Comment 11 Jared 2013-08-31 22:59:53 UTC
I also switched down to 4.0.4 because of same/similar issues with 4.0.5.

(In reply to comment #9)
> Hello!
> 
> In 4.0.5 and 4.1.1 release there is the same behaviour on 64bit and 32bit,
> Win 77 Home and Professional machines:
> 
> If I open a file from a network drive, make modifications and click save
> then the file is not saved with mess: Error saving the document XXXX.ods:
> Access to P:\_Documente personale\Membrii familiei\copiii 2.ods was denied
> that there are no sufficient rights.
> 
> The same behaviour is with quick start on and off.
> 
> For me this is a showstopper, as I cannot use anymore neither 4.0.5 nor
> 4.1.1. Reverting back to 4.0.4 where this did not happen.
Comment 12 Robert Popa 2013-10-06 20:28:03 UTC
Tested with 4.1.2.3 on Win 7 64bit. The problem still remains for some ods files.

However, when I copied the data from the "broken" file to a new file (only numbers and formulas) and I redid the formatting by hand, the file could be saved on the network, so there is hope that something is better, but not yet reliable.

On the local drives I could work without any problems.

For the network scenario I tried with antivirus on/off but could not save.

Apache 4.0.1 worked without problems! on the same files... Too bad it has not yet the functionality of LibreOffice.
Comment 13 Dave 2013-10-18 11:59:02 UTC
I can add a bit of information:

LibO 4.1.2.3
Win 7 Pro 64 bit client
Samba 3.6.3 server

Only odt and ods files get the "Document is locked for editing by Unknown User"; odb, csv, xls and doc don't (these are all set up to open in LibO on my computer)

Looking at the output from smbstatus directly after opening an odt/ods file from the network shows it to be read only:

8931         10000      DENY_WRITE 0x20089     RDONLY     NONE             /home/users/davidm   systems.odt   Fri Oct 18 12:53:43 2013

but this read only status disappears after ~5 seconds. Once it has gone, I can use the "Edit File" button in LibO to get RW access to the file, after which the smbstatus line is the more "normal":

8931         10000      DENY_WRITE 0x2019f     RDWR       NONE             /home/users/davidm   systems.odt   Fri Oct 18 12:55:04 2013
Comment 14 Maxim Monastirsky 2013-10-25 10:36:29 UTC
I think that we can safely close this bug as a dup of Bug 67534. The fact that the latter was a performance issue, explains why the file unlocks after some time.

*** This bug has been marked as a duplicate of bug 67534 ***