Download it now!
Bug 68082 - FILESAVE: File cannot be saved on network drive
Summary: FILESAVE: File cannot be saved on network drive
Status: RESOLVED DUPLICATE of bug 67534
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-13 20:20 UTC by Robert Popa
Modified: 2013-10-28 15:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Popa 2013-08-13 20:20:04 UTC
Problem description: File cannot be saved if Load LibreOffice at startup is checked (LibreOffice quickstart is on). There is a 50-60k system process that doen't quit even if you close the file by cancelling the changes. 
OR
If it saves the file then at the next reopening you cannot modify because the same system process is still on and the file is actually opened...

I could not reproduce it on local files!

Steps to reproduce:
1. Open network ods
2. Make a change
3. Save
4. Error occurs
5. Cancel
6. Quit LO

scenario 2>
1. Open network ods
2. Make a change
3. Save
4. Error doesn't occur and file is saved
5. Try to reopen
6. "File is opened by another user"

The issue is not influenced by antivirus. I tried with webroot on/off, Bitdefender on/off, without... Still the same. 

Also the problem does not appear every time!!!! This is most frustrating...

For further tests/info please instruct me on what to do!

Current behavior:

Expected behavior:

              
Operating System: Windows 7
Version: 4.1.0.4 release
Comment 1 Maxim Monastirsky 2013-08-19 15:38:43 UTC
Hi,

Could you please take a look at bug 67885? I think it's the same as your second scenario (if so it doesn't related to quickstart).

As of your first scenario, you can open the document, but not save afterwards, right?
Comment 2 Mark.Rodehorst 2013-08-23 07:36:27 UTC
Hi, if I am meant:
Scenario 2 is what i got.

I can't reproduce Scenario 1 or don't know how to.
Comment 3 Robert Popa 2013-08-25 19:34:29 UTC
I have looked over  bug 67885 and it behaves similar but not entirely. Also for that bug, when it happened, I had to close the Windows Eplorer window from which I started the file (or at least perform a back and forward on the folder to get a fresh refresh)

Fo the issue described above I found a workaround, which I do not like, but it works. If I do not use Load LibreOffice at startup at all, then the problem does not happen anymore on any of the computers/systems tested! In my opinion this must have something to do with quickstart.
Comment 4 Robert Popa 2013-08-31 19:52:09 UTC
Hello!

In 4.0.5 and 4.1.1 release there is the same behaviour on 64bit and 32bit, Win 77 Home and Professional machines:

If I open a file from a network drive, make modifications and click save then the file is not saved with mess: Error saving the document XXXX.ods:
Access to P:\_Documente personale\Membrii familiei\copiii 2.ods was denied that there are no sufficient rights.

The same behaviour is with quick start on and off.

For me this is a showstopper, as I cannot use anymore neither 4.0.5 nor 4.1.1. Reverting back to 4.0.4 where this did not happen.
Comment 5 Robert Popa 2013-10-06 20:28:33 UTC
Tested with 4.1.2.3 on Win 7 64bit. The problem still remains for some ods files.

However, when I copied the data from the "broken" file to a new file (only numbers and formulas) and I redid the formatting by hand, the file could be saved on the network, so there is hope that something is better, but not yet reliable.

On the local drives I could work without any problems.

For the network scenario I tried with antivirus on/off but could not save.

Apache 4.0.1 worked without problems! on the same files... Too bad it has not yet the functionality of LibreOffice.
Comment 6 Maxim Monastirsky 2013-10-28 11:00:10 UTC
(In reply to comment #4)
> The same behaviour is with quick start on and off.
OK, so I'll correct the summary.
Comment 7 Urmas 2013-10-28 12:42:47 UTC
If you uninstall 'Libreoffice Windows Explorer extension', does the problem persist?
Comment 8 Maxim Monastirsky 2013-10-28 15:26:16 UTC
(In reply to comment #7)
> If you uninstall 'Libreoffice Windows Explorer extension', does the problem
> persist?
@Robert Popa: Following Urmas suggestion: Please run LibreOffice installation, choose 'Modify' and uncheck the installation of Windows Explorer extensions. Does it solve your problem?
Comment 9 Robert Popa 2013-10-28 15:41:18 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > If you uninstall 'Libreoffice Windows Explorer extension', does the problem
> > persist?
> @Robert Popa: Following Urmas suggestion: Please run LibreOffice
> installation, choose 'Modify' and uncheck the installation of Windows
> Explorer extensions. Does it solve your problem?

YES!!! It finally works! I could not get the files blocked anymore. I opened multiple Explorer Windows and every time the files opened correct. 

Regarding save: I did multiple saves, very quick, and still the file did not block me to save it.

I guess this was the problem. However, why did we need the Windows Eplorer Extension in the first place? I don't know what it is used for... :(
Comment 10 Maxim Monastirsky 2013-10-28 15:46:36 UTC
(In reply to comment #9)
> YES!!! It finally works!
Great, thanks for confirming!

*** This bug has been marked as a duplicate of bug 67534 ***