Bug Hunting Session
Bug 67914 - Formatting of text within a drawing in Visio format is not placed horizontally correctly
Summary: Formatting of text within a drawing in Visio format is not placed horizontall...
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libvisio (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-08 18:11 UTC by m_josenhans
Modified: 2017-10-30 11:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Horizontally and vertically incorrect alignment of text with Visio diagram. (61.54 KB, application/x-zip-compressed)
2013-08-08 18:11 UTC, m_josenhans
Details
screenshot - VisioViewer (12.72 KB, image/png)
2015-12-31 13:07 UTC, David Tardon
Details
screenshot - LibreOffice (16.43 KB, image/png)
2015-12-31 13:07 UTC, David Tardon
Details
sample diagram (140.50 KB, application/vnd.visio)
2015-12-31 13:08 UTC, David Tardon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m_josenhans 2013-08-08 18:11:39 UTC
Created attachment 83860 [details]
Horizontally and vertically incorrect alignment of text with Visio diagram.

Horizontally incorrect allingment of text with Visio diagram.

A Viso drawing with a horizontally incorrect allignment in LibreOffice 4.0.3.3.

This error appears on Windows and Linux.

See attached zip file. The error is cloasely realted to #67913.
Comment 1 Mike Kaganski 2013-08-09 01:44:26 UTC
Reproducible with 4.1.0.4 under Win7x64.
Comment 2 Julien Nabet 2013-08-24 06:41:20 UTC
On pc Debian x86-64 with master sources updated yesterday, I reproduced the problem.
Comment 3 QA Administrators 2015-04-01 14:40:32 UTC Comment hidden (obsolete)
Comment 4 Mike Kaganski 2015-04-02 09:04:41 UTC
Still REPRODUCIBLE with Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: ru_RU
Comment 5 David Tardon 2015-12-31 13:07:01 UTC
Created attachment 121662 [details]
screenshot - VisioViewer
Comment 6 David Tardon 2015-12-31 13:07:21 UTC
Created attachment 121663 [details]
screenshot - LibreOffice
Comment 7 David Tardon 2015-12-31 13:08:27 UTC
Created attachment 121664 [details]
sample diagram
Comment 8 Fridrich Strba 2016-01-15 11:05:27 UTC
This libvisio commit http://cgit.freedesktop.org/libreoffice/libvisio/commit/?id=49e7e5482d979866ac92981af0cf83d09610bc80 fixes this bug. Unfortunately, it is unlikely that this fix will make it to LO 5.1.0. I am closing it anyway, since I fixed it :)