Download it now!
Bug 67916 - Text cursor does not follow VoiceOver cursor to a different paragraph (OSX 10.8)
Summary: Text cursor does not follow VoiceOver cursor to a different paragraph (OSX 10.8)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2013-08-08 18:57 UTC by Boris Dušek
Modified: 2017-01-03 19:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Boris Dušek 2013-08-08 18:57:03 UTC
Summary: 

Steps to reproduce:
1. Have a text in Writer with 2 paragraphs
2. Put text cursor in the first one of them
3. Switch VoiceOver on (Cmd+F5), notice it focuses on the paragraph with keyboard focus (= first paragraph)
4. Move VoiceOver cursor to the next paragraph (VO-right arrow)

Expected results:
Keyboard focus moves to the next (second) paragraph

Actual results:
Keyboard focus stays at the current (first) paragraph

Regression:
Tested on OS X 10.8.4 with LO 4.2 master (specifically 39a78087890fb9255a5e47220bac6cfb956fcfe0).

Notes:
Ideally all the paragraphs would form a single virtual text area using AXSharedTextUIElements, but that's another story for a time when more serious bugs will be fixed.
Comment 1 Alex Thurgood 2014-12-01 14:24:54 UTC
Can not reproduce with OSX 10.10.1 and LO 4341

Switching paragraphs down via Cmd-Option-Down arrow works and reads out text paragraph
Comment 2 Alex Thurgood 2014-12-01 14:50:15 UTC
setting as wfm
Comment 3 Boris Dušek 2014-12-03 19:52:59 UTC
(In reply to Alex Thurgood from comment #1)
> Can not reproduce with OSX 10.10.1 and LO 4341
> 
> Switching paragraphs down via Cmd-Option-Down arrow works and reads out text
> paragraph

By "can not reproduce", do you mean that when doing "Steps to reproduce" 1.-5. exactly as I described them, you get the "Expected results" and no longer the "Actual results"?

Unless that is the case, this bug cannot be closed, because no matter if you find another way to switch paragraphs (like Cmd-Option-arrow down), moving VoiceOver cursor from one paragraph object to another must move also the keyboard focus with it, as described in "Expected results".
Comment 4 Alex Thurgood 2014-12-05 14:36:45 UTC
Ah, opk, I misunderstood, sorry about that, I thought it was just about VoiceOver reading out the correct paragraph with the keyboard command switch. Confirming.
Comment 5 Robinson Tryon (qubit) 2015-12-10 03:37:41 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-01-03 19:40:42 UTC Comment hidden (obsolete)
Comment 7 Boris Dušek 2017-01-03 19:50:51 UTC
macOS 10.12.2
LibreOffice 5.2.4