Download it now!
Bug 67951 - FILEOPEN / DOC FILTER: cropped image in doc file is imported incorrectly in writer
Summary: FILEOPEN / DOC FILTER: cropped image in doc file is imported incorrectly in w...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:doc
Depends on:
Blocks:
 
Reported: 2013-08-09 14:23 UTC by Stephan van den Akker
Modified: 2015-12-17 05:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document with a cropped bitmap grouped with a line. (27.50 KB, application/msword)
2013-08-09 14:23 UTC, Stephan van den Akker
Details
Screenshot of Word 97 with sample document (24.41 KB, image/png)
2013-08-24 08:37 UTC, Stephan van den Akker
Details
Screenshot of Word 2007 with sample document (37.53 KB, image/png)
2013-08-24 08:37 UTC, Stephan van den Akker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan van den Akker 2013-08-09 14:23:52 UTC
Created attachment 83892 [details]
Sample document with a cropped bitmap grouped with a line.

Attaching a sample document created in MSO 97:

Created by:
- grouping a cropped bitmap and a line in Powerpoint
- copying to Word
- saving to .doc

The bitmap in this sample file is imported by LO without cropping, but scaled. The cropped part of the bitmap is red with the text "Invisible square". It should not be visible. Any vector element will cause this, not just lines.

If the cropped bitmap and the line are ungrouped in Word prior to saving, than the cropped bitmap is imported correctly by newer versions of LO. (Only the green part of the bitmap is visible). 

Tested on Windows XP (32-bit):

OpenOffice.org 3.3.0
OOO330m20 (Build:9567)


Tested on openSuSE 11.4 64-bit with: 

LO Version 4.0:build-303 (Build ID: 400m0(Build:303))

LO Version: 4.2.0.0.alpha0+
Build ID: 784cfa382be438240dfc936b7551c5012aada9ae

Version: 4.2.0.0.alpha0+
Build ID: 8716aa29fe4b4309fec71ef6a21ccbdd1f3b7f9e
Comment 1 tommy27 2013-08-23 17:18:19 UTC
tested with LibO 3.3.3, 4.0.4 and 4.1.0 under Win7 64bit.
I see the "invisible" red square in your test document.

so the same .doc file opened in Word should show only the green square, right?
Comment 2 Stephan van den Akker 2013-08-23 18:18:54 UTC
Correct: In Word only the green square is visible.
Comment 3 tommy27 2013-08-24 07:30:45 UTC
unfortunately I have no MS Word to confirm that.
is there any other user who can confirm difference between Word and Writer?
Comment 4 Stephan van den Akker 2013-08-24 08:37:06 UTC
Created attachment 84549 [details]
Screenshot of Word 97 with sample document
Comment 5 Stephan van den Akker 2013-08-24 08:37:58 UTC
Created attachment 84550 [details]
Screenshot of Word 2007 with sample document
Comment 6 Stephan van den Akker 2013-08-24 08:52:40 UTC
Cor Nouws and Miklos Vajna already confirmed this bug in the discussion on bug 57378.
Comment 7 tommy27 2013-08-24 11:22:17 UTC
@Stephan

ok. changing status to NEW.
so basically Bug 67951 and Bug 57378 are the same issue respectively with .doc and .docx formats.
Comment 8 Stephan van den Akker 2013-08-24 19:32:19 UTC
Well, AFAICS (not deeply versed in the LO code) there are two different fail mechanisms. 

Bug 57378 seems to be fixed in the latest LO versions. Probably some parameters from a docx file not being parsed correctly during import.

This bug however, is not fixed.

I observed that when a picture (bitmap) is part of a drawing that also contains vector elements, the bitmap part is no longer stored as a Writer picture. E.g. the context menu of the bitmap part doesn't have the "Picture" item associated with it. Writer pictures have. Therefore the cropping functionality in Writer for pictures is not available for these elements.

Not sure if docx documents will have the same problem.
Comment 9 QA Administrators 2015-09-04 02:47:35 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 10 tommy27 2015-09-06 11:42:08 UTC
retested under Win8.1 x64
now Writer 4.4.5 renders the document exactly as the MS Word screenshot

so the bug is RESOLVED WORKSFORME
Comment 11 Robinson Tryon (qubit) 2015-12-17 05:51:11 UTC
Migrating Whiteboard tags to Keywords: (filter:doc)
[NinjaEdit]