Bug 67974 - UI: Add a search box in function wizard in Spreadsheet
Summary: UI: Add a search box in function wizard in Spreadsheet
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: abhilash300singh
URL:
Whiteboard: BSA target:5.3.0
Keywords: difficultyInteresting, easyHack, skillCpp, topicUI
Depends on:
Blocks: Function-Wizard
  Show dependency treegraph
 
Reported: 2013-08-10 08:40 UTC by Soumya Boral
Modified: 2017-02-14 08:58 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of function wizard is attached. Please add the search box in the red marked area. (47.30 KB, image/jpeg)
2013-08-10 08:40 UTC, Soumya Boral
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Soumya Boral 2013-08-10 08:40:17 UTC
Created attachment 83917 [details]
Screenshot of function wizard is attached. Please add the search box in the red marked area.

Problem description: There is no search box in function wizard which may help to find out a particular function. If we want to know which function to use to find correlation coefficient between two data sets, then we have to click on each function name, read the description and then after a lot of work we can find out the function. But if there is a search box which searches not only function names, but also the description of the functions, then we will type "correlation coefficient" in the search box and it will show us that this word appears in the description of the function "CORREL". This will help to find the exact function with much less time.

Steps to reproduce:
1. Add a search box in function wizard of spreadsheet.
2. Make sure that it searches not only the function names but also the descriptions of the functions.
3. Make sure that the search box displays all possible functions whose names and/or descriptions contain the search box query.

Current behavior: No search box exists in the Function Wizard of Spreadsheet.

Expected behavior: A search box which will search not only the function names but also the description of functions and will display all possible functions whose names and/or descriptions contain the search box query.

              
Operating System: All
Version: 4.1.0.4 release
Comment 1 Soumya Boral 2013-08-10 13:15:27 UTC
I have mistakenly written wrong things in Steps to reproduce. I am writing them here:-

Steps to reproduce :- 

1) Open Spreadsheet and then open function wizard.
2) You will find that there is no search box there.
Comment 2 retired 2013-08-10 17:53:58 UTC
Since Excel does have this feature and I agree it would be very handy
confirming and setting to NEW
Comment 3 Soumya Boral 2013-11-11 14:34:07 UTC
(In reply to comment #2)
> Since Excel does have this feature and I agree it would be very handy
> confirming and setting to NEW

Thanks to see that you like this function. Hope that more people like this feature and it got noticed by the developers.
Comment 4 QA Administrators 2015-04-19 03:22:36 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-06-18 14:56:58 UTC
Setting to enhancement.
Comment 6 Samuel Mehrbrodt (CIB) 2016-06-29 20:15:32 UTC
EasyHack:
The glade files are formula/uiconfig/ui/formuladialog.ui and formula/uiconfig/ui/functionpage.ui.

Please put the search box below the category in functionpage.ui.

The code is in the class "FuncPage" in formula/source/ui/dlg/funcpage.cxx.
Comment 7 Xisco Faulí 2016-09-10 22:29:33 UTC
Hi Abhilash,
Please, next time you assign a bug to yourself, remember to change the status and the assignee.
Regards
Comment 8 Buovjaga 2016-09-12 16:59:27 UTC
Abhilash: next time you are working on an easy hack, please only leave a comment saying you are working on it. This is the preferred way as many people forget to change the status/etc. back in case they abandon work.
Comment 9 jani 2016-09-13 09:10:33 UTC
(In reply to Buovjaga from comment #8)
> Abhilash: next time you are working on an easy hack, please only leave a
> comment saying you are working on it. This is the preferred way as many
> people forget to change the status/etc. back in case they abandon work.

For easyHack (in contrast to normal bugs) we suggest people to ASSIGN them unless it is one of the generic ones (change <foo> to <xfoo>) where many people can work in parallel.

The reason behind assigning, is simply that if not assigned the appear in different lists and cause confusion.

Non easyhacks are normally done by more skilled and therefore known developers, which means there are no real need to assign them.

The wiki getInvolved page suggest to use assign.
Comment 10 abhilash300singh 2016-09-28 03:45:38 UTC
Thanks for correcting my mistakes. Would take care in future.
Comment 11 abhilash300singh 2016-09-28 04:48:04 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #6)
> EasyHack:
> The glade files are formula/uiconfig/ui/formuladialog.ui and
> formula/uiconfig/ui/functionpage.ui.
> 
> Please put the search box below the category in functionpage.ui.
> 
> The code is in the class "FuncPage" in formula/source/ui/dlg/funcpage.cxx.

I've done this much(just adding a search box and a label to the .ui file). This was of course the easier part. The tougher part would be to actually implement the search function and display the results. Can you point me to an example, somewhere in LO, which implements a similar feature. That would be really helpful. If not, any suggestions on where to start from would be helpful.

I would like to explain the task a little bit. The idea is to type something in the search box. Accordingly, the code should search in the list of functions as well as their description. Does this need to be realtime, as in - the results change as the user types? Also, I'm still not sure how/where the results would be displayed. The obvious choice would be to show them where the current list of functions reside, just below the category drop-down. But then, I think, an added functionality would be needed, which also filters the results depending on the category chosen. We might chose to disable the category drop-down otherwise. Correct me if I'm wrong anywhere. Any suggestions would be highly helpful.

Thanks.
Comment 12 Eike Rathke 2016-10-10 20:39:00 UTC
I'd probably implement the result list as an additional category where we now have "Last Used", "All", "Database", ... we could also have "Search Result" or some such (e.g. between "Last Used" and "All") and treat it similar to the "Last Used" category. This way all the existing functionality of the Function Wizard can be used also with the search results.
Comment 13 abhilash300singh 2016-10-15 02:55:00 UTC
(In reply to Eike Rathke from comment #12)
> I'd probably implement the result list as an additional category where we
> now have "Last Used", "All", "Database", ... we could also have "Search
> Result" or some such (e.g. between "Last Used" and "All") and treat it
> similar to the "Last Used" category. This way all the existing functionality
> of the Function Wizard can be used also with the search results.

That would be nice, re-using the functionality of Function Wizard. I will reassign this to myself later, when I've gathered enough knowledge around the topic. Till then, anyone else is free to try this out. Thanks.
Comment 14 Eike Rathke 2016-10-24 12:52:10 UTC
Please do not assign yourself as QA contact.
Comment 15 Commit Notification 2016-10-29 15:34:04 UTC
Abhilash Singh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=70e97ade2f8dd6f61574dca985074f550db0630f

tdf#67974 UI: Add a search box in function wizard in Spreadsheet

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2016-10-29 16:00:51 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a0318e4f81ed4ec8871010669a300f6aff4e80d

filter hidden functions also in search, tdf#67974 follow-up

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2016-10-29 17:27:04 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c857e5ef42266485619587198dcf4599cf995935

display matching search per selected category, tdf#67974 follow-up

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 jani 2016-10-31 07:44:12 UTC
seems solved