Bug 68115 - [Autofilter] Additional options (on top of window) are not accessible by Alt + letter shortcut
Summary: [Autofilter] Additional options (on top of window) are not accessible by Alt ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility, needsDevEval
Depends on:
Blocks: a11y AutoFilter
  Show dependency treegraph
 
Reported: 2013-08-14 16:25 UTC by Mirosław Zalewski
Modified: 2021-07-28 10:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample AutoFilter pop-up window. Note how "S" in "Standard filter" is underlined (15.62 KB, image/png)
2013-08-14 16:25 UTC, Mirosław Zalewski
Details
Sample file with autofilter (8.34 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-05 21:02 UTC, Mirosław Zalewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirosław Zalewski 2013-08-14 16:25:05 UTC
Created attachment 84064 [details]
Sample AutoFilter pop-up window. Note how "S" in "Standard filter" is underlined

In all menus, one can press Alt + underlined letter to quickly go to entry of choice.

This does not work in AutoFilter pop-up window. One might expect to press Alt + Letter to sort ascending, descending, open Standard filter window or change state of "All" checkbox, but it is not possible.

Furthermore, Calc *DOES* underline "s" in "Standard filter..." entry, giving user illusion that he can press Alt + s to open this window (see attached screenshot). This is probably caused by copying string from Data → Filter submenu.

Please add such ability.
Comment 1 Joel Madero 2014-05-05 04:02:48 UTC
Please provide a sample document and clearer steps (enumerated work best). 

Marking as NEEDINFO - once clear steps are provided and a sample document (simple please) mark as UNCONFIRMED and we'll try to confirm. Thanks
Comment 2 Mirosław Zalewski 2014-05-05 21:02:12 UTC
Created attachment 98515 [details]
Sample file with autofilter

OK, let me try:

1. Open attached file (or create one and apply autofilter)
2. Look at menu bar of LibreOffice; notice how "o" is underlined in "Format"
3. Press Alt + o; Format menu will pop up.
4. Notice how menu items have one letter underlined. Press Alt + that letter to choose certain option. For example, Alt + p will open Page settings window.
5. Open autofilter window in sheet; in attached document, press drop-down arrow in cell A1.
6. Notice how "s" in "Standard filter" is underlined.
7. Press Alt + s

ACTUAL RESULTS:
Nothing happens.

EXPECTED RESULTS: 
"Standard filter" option is selected, filter window pops up.
All other menus in LibreOffice teaches user that he can press Alt + underlined letter to select certain option in UI; this way, UI can be used by keyboard only, without mouse. But in this particular case, that method does not work. UI hints user that he may choose "Standard filter" option using only Alt + s keyboard shortcut, while, in fact, he can not.
This should be made consistent. Either Alt + s should open "Standard filter" window, or underline should be removed from "s".
Comment 3 Kevin Suo 2014-07-07 16:14:46 UTC
Hi Mirosław Zalewski,
 
Can you still reproduce with the newest libreoffice version? I do not reproduce with 4.3.0.2, Fedora 20 x86. Pressing Alt+S opens the Standard Filter dialog.

Thanks!
Comment 4 Mirosław Zalewski 2014-07-07 20:39:21 UTC
Hi Kevin,

Yes, I can still reproduce this issue using LibreOffice 4.3.0.2 (Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409) on Windows 7 (x86) machine.
Comment 5 Joel Madero 2014-07-16 20:41:34 UTC
Confirmed. This seems like more of a bug than an enhancement request to be honest. Underline implies ability to open with alt + letter.

New
Minor - can slow down professional quality work but won't prevent it
Medium - I believe that this could impact people with visual impairment, also for consistency purposes bumping up to medium.

Might be an easy thing to resolve, requesting input for that.

@Miroslaw - thanks for the awesome instructions and sample document
Comment 6 Robinson Tryon (qubit) 2015-12-13 11:21:22 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-01-03 19:50:47 UTC Comment hidden (obsolete)
Comment 8 Roman Kuznetsov 2019-02-03 19:18:05 UTC
still repro in

Версия: 6.3.0.0.alpha0+
ID сборки: 51af3179cf972809d6495c7d58033e069f647bbf
Потоков ЦП: 4; ОС:Linux 4.18; Отрисовка ИП: по умолчанию; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-01_00:15:00
Локаль: ru-RU (ru_RU.UTF-8); UI-Language: ru-RU
Calc: threaded
Comment 9 b. 2020-10-07 08:11:33 UTC
despite c#4 say's ver. win i couldn't repro in calc 3.5.1.2, 6.1.6.3, 6.2.8.2, 7.0.0.2, 7.1.0.0.a0+ under win7(x64), 

neither with own nor the provided sample, 

dependent on any settings? 

or 'lin-only'?
Comment 10 Henry 2021-02-06 12:14:07 UTC
- I am unable to activate "Alle" by using Alt + E on my keyboard.
- Same is true for any other button, say "Ok" at the bottom of the autofilter popup menu, I cannot activate the button by using ALT + O.

Sample GIF/WEBM (click on HD in the lower right corner to view video in better resolution): https://gfycat.com/dentalforkedalpaca

OS: linux 5.10.13.arch1-1
LO: libreoffice-still 7.0.4-1
Comment 11 stragu 2021-06-04 13:39:38 UTC
In the latest master build of LO 7.2 for Linux, there is no erroneous underline of the "S" in "Standard filter".

The only three items that have an underline for a shortcut are:

- _A_ll
- _O_K
- _C_ancel

I tested them and they all work. Henry, you might want to try again with the latest version? Hopefully not an issue with the DE locale.

However, none of the options at the top have an Alt shortcut:

- Sort Ascending
- Sort Descending
- Top 10
- Empty
- Not Empty
- Text color
- Background color
- Standard Filter...

So I guess this bug report is now about adding Alt shortcuts for all items in that top list.
Comment 12 Henry 2021-07-25 19:19:31 UTC
Well, I'm quite happy to report that with
Name: 		libreoffice-fresh
Version:	7.1.5-1
everything works as intended now. As far as I can tell, that is. :)

See here: https://gfycat.com/recentspiritedafricanaugurbuzzard

Please do note that I did not switch to a more colorful theme so all the focus markings are not that attention grabbing, perhaps not much distinguishable at all. But it's a dotted or dashed grey rectangle.