Bug 68119 - Cannot read/write from/to network file server (Samba/cifs) on Ubuntu 13.04
Summary: Cannot read/write from/to network file server (Samba/cifs) on Ubuntu 13.04
Status: RESOLVED DUPLICATE of bug 67527
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-14 17:32 UTC by jim
Modified: 2013-08-15 16:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jim 2013-08-14 17:32:27 UTC
Network file server running Alt-F, cifs and Samba
Status shows our connection to Swerver is using cifs.

Loaded 4.1.0.4-4 from LibreOffice site, installed the DEB files
Double click on Network .xlsx file - Calc starts and then disappears with no message.
Drag file from network onto open calc - get unable to load file - insufficient permissions.
Copy file to local storage then opens OK. Attempt to save on network will not allow save as then shows file is read-only. Can save a copy but same issues using that copy.
Tried using bpth SMB: and mount point

Removed "Uninstalled" all libreoffice files using Synaptic PM
Installed 4.0.2.2 from Ubuntu rep - no problems except they have butchered the package to use Global Menu Bar which will not uninstall.
Comment 1 jim 2013-08-14 17:36:15 UTC
Can edit, save files etc OK using gedit
When using 4.1.0.4-4 cannot see lock file (can with Ubuntu v 4.0.2.2)
Comment 2 Cor Nouws 2013-08-14 20:05:51 UTC
Hi jim,

could this be related to bug 67885  ?
Comment 3 jim 2013-08-14 23:55:46 UTC
I can't say it's not related.
Bug 67885 is able to open & save then close and if re-opened within 30 
seconds it is write protected
Bug 68119 can open but not save (I am pretty sure the save was attempted 
after more than 30 seconds from opening as I was looking through quite a 
large spreadsheet and did a minor edit). On subsequent tests with 
different spreadsheets it would have only been a short period of time.
Can't try it again because I have reverted to Ubuntu version as it is on 
a production system.


On 14/08/13 21:05, bugzilla-daemon@freedesktop.org wrote:
> Cor Nouws <mailto:cno@nouenoff.nl> changed bug 68119 
> <https://bugs.freedesktop.org/show_bug.cgi?id=68119>
> What 	Removed 	Added
> CC 		cno@nouenoff.nl
>
> *Comment # 2 <https://bugs.freedesktop.org/show_bug.cgi?id=68119#c2> 
> on bug 68119 <https://bugs.freedesktop.org/show_bug.cgi?id=68119> from 
> Cor Nouws <mailto:cno@nouenoff.nl> *
> Hi jim,
>
> could this be related tobug 67885  <show_bug.cgi?id=67885>   ?
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 4 Maxim Monastirsky 2013-08-15 13:45:40 UTC
It's a dup of bug 67527. Bug 67527 is only about opening, but according to my tests the saving problem reproducible only in cases where bug 67527 also reproducible (see bug 67527 comment 16 & 17), so I'm pretty sure it's the same bug.

@jim: As a user of Ubuntu 13.04, currently you have two solutions:
1) Install LO 4.1 from PPA (not from libreoffice.org) - It will fix both opening and saving.
2) Apply the workaround from bug 67527 comment 15 - Unfortunately it will fix only opening.

Feel free to reopen the bug if you disagree.

*** This bug has been marked as a duplicate of bug 67527 ***
Comment 5 jim 2013-08-15 16:50:29 UTC
Thank you Maxim - I will try it out soon.

On 15/08/13 14:45, bugzilla-daemon@freedesktop.org wrote:
> Maxim <mailto:momonasmon@gmail.com> changed bug 68119 
> <https://bugs.freedesktop.org/show_bug.cgi?id=68119>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	RESOLVED
> Resolution 	--- 	DUPLICATE
>
> *Comment # 4 <https://bugs.freedesktop.org/show_bug.cgi?id=68119#c4> 
> on bug 68119 <https://bugs.freedesktop.org/show_bug.cgi?id=68119> from 
> Maxim <mailto:momonasmon@gmail.com> *
> It's a dup ofbug 67527  <show_bug.cgi?id=67527>.Bug 67527  <show_bug.cgi?id=67527>  is only about opening, but according to my
> tests the saving problem reproducible only in cases wherebug 67527  <show_bug.cgi?id=67527>  also
> reproducible (seebug 67527 comment 16  <show_bug.cgi?id=67527#c16>  & 17), so I'm pretty sure it's the same
> bug.
>
> @jim: As a user of Ubuntu 13.04, currently you have two solutions:
> 1) Install LO 4.1 from PPA (not from libreoffice.org) - It will fix both
> opening and saving.
> 2) Apply the workaround frombug 67527 comment 15  <show_bug.cgi?id=67527#c15>  - Unfortunately it will fix
> only opening.
>
> Feel free to reopen the bug if you disagree.
>
> *** This bug has been marked as a duplicate ofbug 67527  <show_bug.cgi?id=67527>  ***
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>