Bug 68124 - Cross-reference building blocks needed
Summary: Cross-reference building blocks needed
Status: RESOLVED DUPLICATE of bug 121945
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields-Cross-Reference
  Show dependency treegraph
 
Reported: 2013-08-14 23:04 UTC by Bruce Byfield
Modified: 2019-02-05 18:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Byfield 2013-08-14 23:04:45 UTC
LO's cross-reference tool centers on the source and reference. However, a complete cross-reference also consists of what might be called "building blocks" -- short phrases that link the source fields.

For example: "For more information, see "[REFERENCE]," page [PAGE].Here, 'For more information, see "' and '," page' would be building blocks.

You can use macros or AutoText for entering building blocks, but this method is clumsy because it requires juggling dialog windows. A more efficient solution would be to build and display building blocks in the same window as the cross-references, so that they can be added along with the source fields.

A tool like those for organizing table of contents element might be useful.
Comment 1 tommy27 2013-08-20 16:55:07 UTC
@Bruce Byfield
is this a feature request, right?
Comment 2 Bruce Byfield 2013-08-20 17:18:53 UTC
(In reply to comment #1)
> @Bruce Byfield
> is this a feature request, right?

Yes.
Comment 3 tommy27 2013-08-20 17:47:36 UTC
setting as NEW. this is an enhancement request so version field must be first LibO release: 3.3.0
Comment 4 Dieter Praas 2017-05-28 10:59:44 UTC
I'm not sure, whether I grasp the enhancement request. I don't know what improvements are in the cross-reference dialog between LO 3.3 an LO 5.3, but I think you can create the requested kind of reference via the type "set reference". You can create short or longer phrases as a reference. But I'm not sure, if this is exactly what you want to achieve.
Comment 5 Cor Nouws 2019-02-05 18:59:30 UTC
closing as dupe of 121945, which has fuller explanation

*** This bug has been marked as a duplicate of bug 121945 ***