Bug Hunting Session
Bug 68188 - REPORTBUILDER: Forced Page Break property for sections
Summary: REPORTBUILDER: Forced Page Break property for sections
Status: RESOLVED DUPLICATE of bug 67109
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-16 14:48 UTC by Dan Lewis
Modified: 2013-08-16 15:36 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Lewis 2013-08-16 14:48:06 UTC
Problem description: 
When selection the properties for a section (header, detail, or footer), one of them is the Force New Page with four choices: None, Before, After, Before and After. The page breaks that are actually set in the report do not match the selection made


Steps to reproduce:
1. Open the Report Builder.
2. Select a table, query, or view as the data source.
3. Add a grouping header.
4. Add the grouping control to the grouping header.
5. Add a control to the Detail section.
6. Experiment with different settings for "Force New Page" in either the grouping header or Detail section.

Current behavior:
None: the page breaks appears after the last control of the section.
Before: the page break appears before and after the section.
After: the page break appears before the section.
Before and after: no page breaks appear.

Expected behavior:
None: no page breaks
Before: the page break appears before the section.
After: the page break appears after the section.
Before and after: page breaks appear before the first control in the section and after the last control in the section.
              
Operating System: Debian
Version: 4.1.0.4 release
Comment 1 Robert Großkopf 2013-08-16 15:36:21 UTC

*** This bug has been marked as a duplicate of bug 67109 ***