Bug Hunting Session
Bug 68190 - REPORTBUILDER: Force New Page section property
Summary: REPORTBUILDER: Force New Page section property
Status: RESOLVED DUPLICATE of bug 67109
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-16 15:00 UTC by Dan Lewis
Modified: 2013-08-16 15:35 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Lewis 2013-08-16 15:00:59 UTC
Problem description: 
This property sets where the page breaks will be in a report. However, the names in this property do not match where the page breaks are set. (See Current and Expected behaviors below)

Steps to reproduce:
1. Open Report Builder
2. Select a query, table, or view for the data source.
3. Add a grouping header for one of the fields of the data source.
4. Add some controls to the Detail section.
5. Experiment with various settings of the Force New Page property.

Current behavior:
None: the page breaks appears after the last control of the section.
Before: the page break appears before and after the section.
After: the page break appears before the section.
Before and after: no page breaks appear.

Expected behavior:
None: no page breaks 
Before: the page break appears before the section.
After: the page break appears after the section.
Before and after: page breaks appear before the first control of the section and after the last control of the section.
              
Operating System: Debian
Version: 4.1.0.4 release
Comment 1 Robert Großkopf 2013-08-16 15:35:48 UTC

*** This bug has been marked as a duplicate of bug 67109 ***