Bug Hunting Session
Bug 68202 - Make sure that the app doesn’t block multiple concurrent sessions, either locally or remotely
Summary: Make sure that the app doesn’t block multiple concurrent sessions, either loc...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-08-16 18:27 UTC by Jesus Corrius
Modified: 2014-12-11 14:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesus Corrius 2013-08-16 18:27:53 UTC
Make sure that the app doesn’t block multiple concurrent sessions, either locally or remotely. The app must not depend on global mutexes or other named-objects to check for or block multiple concurrent sessions. If the app can’t allow multiple concurrent sessions per user, use per-user or per-session namespaces for mutexes or other named-objects. See link below for more information:

http://msdn.microsoft.com/library/windows/desktop/aa383490(v=vs.85).aspx

There's a AOO patch that fixes the problem, but it does by blocking more than one instance of LibreOffice and showing an error message. This doesn't work for us as we should be able to open several instances in the same session on Windows 7+ (so we can pin them in the TaskBar).

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b218cbf59de4d7ae0a6962995fb0f719ed68b5d2
Comment 1 V Stuart Foote 2013-08-17 17:32:41 UTC
Working with current Windows build of Master and was opening error dialog "You have another instance running in a different terminal session. Close that instance and then try again." 

Occurs when attempting to launch multiple sessions--writer and writer, or writer and calc.  So start menu and task bar launchers can not be used--Windows 7 & 8 isnot updating jumplist "recent" for pin'd launchers.  Currently only way to launch additional LO components is from a single start center or one of its children.

Worked backward through my /a admin installs of Master, error message present in 2013-07-31 build
Version: 4.2.0.0.alpha0+
Build ID: d49e3805c58b2c08c5cb0483ed620ab6ef86fedd

not present in the 2013-07-25 build
Version: 4.2.0.0.alpha0+
Build ID: bfa3f8584b2f2492f5c0573f22e4ebd96d9a8af5
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-07-25_22:29:07

So this patch results in regression of Windows function.
Comment 2 V Stuart Foote 2013-08-17 18:28:16 UTC
Fridrich, Jesús

Since the b218cbf59de4d7ae0a6962995fb0f719ed68b5d2 commit breaks local Windows multi-session function pretty badly--should the AOO originated patch simply be reverted and a different solution to the TS/RDS corner case issues be investigated?

Stuart
Comment 3 Jesus Corrius 2013-08-17 18:55:06 UTC
Hi Stuart,

> Since the b218cbf59de4d7ae0a6962995fb0f719ed68b5d2 commit breaks local
> Windows multi-session function pretty badly--should the AOO originated patch
> simply be reverted and a different solution to the TS/RDS corner case issues
> be investigated?

Yes, I have already sent a request to revert it:

https://gerrit.libreoffice.org/#/c/5415/

It's just that we are in the middle of the discussion too see whether we revert it or try to fix it. The intention of the patch is good, but the more i look at it the more i think this has to be done in a different way and the patch has to go for good.
Comment 4 V Stuart Foote 2013-08-19 17:49:00 UTC
Pulled today's TB-39 of master
Version: 4.2.0.0.alpha0+
Build ID: 9a1aca007fd06f3f8223ee02a79e44099d778b51

The reversion of the TS/RDS patch has restored LO multi-session function.
Comment 5 retired 2014-12-11 10:40:07 UTC
Stuart, Jesus: What's up with this one here? The revert request went through it looks like. So now? Is this issue still happening with 4.4b2?
Comment 6 V Stuart Foote 2014-12-11 14:42:44 UTC
Not clear if another method to permit launch of multiple  concurrent TS sessions on Windows, is yet supported. Original AOO patch was not suitable for our needs.

It is still not correct to my knowledge, but do not recall any fuss from users attempting remote desktop TS sessions, so very much a corner case.

@Jesús, *, if additional work is planned please reopen and annotate.