Bug 68320 - Impress <count> behaves oddly when printing handouts without hidden slides
Summary: Impress <count> behaves oddly when printing handouts without hidden slides
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Dialog Handout-View
  Show dependency treegraph
 
Reported: 2013-08-20 09:46 UTC by Tiiti Kellomaki
Modified: 2019-08-11 19:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
nbpage.odp (with hidden slide) (11.79 KB, application/vnd.oasis.opendocument.presentation)
2014-06-07 15:58 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tiiti Kellomaki 2013-08-20 09:46:55 UTC
I have an Impress presentation with 10 slides. Handout master contains "<number>/<count>" (Page number / Page count) which is supposed to give page numbering on the handouts: 1/2, 2/2. Works fine so far. I'm using 6 slides per page on the handout.

When I hide slides 1-5 and print a handout (or select "Range and copies" -> "Slides 6-10" in the Print dialog), I expect to have one page of handout, thus numbered 1/1. Instead, I'm getting one page numbered 1/2. So the <count> is calculating the hidden (or not selected) slides though they will not be printed. Seems to work equally with 1 or 4 slides per handout.

Please either change the <count> to include only the slides to be printed, or change its name to "Total page count" instead of "Page count". At least to me, "Page count" means "the number of paper sheets that will come out from the printer."
Comment 1 pierre-yves samyn 2014-06-07 15:57:06 UTC
Hi

I reproduce on windows 7/64 & 4.3.0.0.beta1

Also reproduced with Version: 4.3.0.0.beta2
Build ID: a06aa316117a6ff0f05c697c82831c227812d810

I set status to New.

The fix for bug 74383 solved the problem of "page count" when hidden slides but as stated in the Bug 74383, comment 8 inconsistent with the page number persists

See the nbpage.odp attached

Regards
Pierre-Yves
Comment 2 pierre-yves samyn 2014-06-07 15:58:00 UTC
Created attachment 100612 [details]
nbpage.odp (with hidden slide)
Comment 3 QA Administrators 2016-02-21 08:35:35 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-03-06 15:18:31 UTC Comment hidden (obsolete)
Comment 5 Samuel Thibault 2017-04-29 18:49:46 UTC
Hello,

This bug still happens with version 5.2.6.2. Notably, doing this gets
odd results:

- create 3 slides
- hide the second slide
- on the third slide, "insert" "field" "page number", then type " / ",
  then "insert" "field" "page count".

The result is 3/2, which is quite peculiar :)

The "page number" should only increment with non-hidden slides.
Comment 6 QA Administrators 2018-09-25 02:51:16 UTC Comment hidden (obsolete)
Comment 7 Samuel Thibault 2018-10-07 18:57:28 UTC
Hello,

I can confirm the issue is still there in master, tested with 

Version: 6.2.0.0.alpha0+
Build ID: 6dacf9ec5455bdad82e78470a1a7cb6d2271bec7