Download it now!
Bug 68431 - FILESAVE: Style Font name incompatible with older versions
Summary: FILESAVE: Style Font name incompatible with older versions
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.1.1 rc
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:4.2.0 target:4.1.3
Keywords: regression
: 70855 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-08-22 13:06 UTC by Theo
Modified: 2013-10-25 08:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test.odp (507.79 KB, application/vnd.oasis.opendocument.presentation)
2013-08-23 05:48 UTC, Theo
Details
screenshot of 4.1.1.1 on Windows 7 (32-bit) (208.26 KB, image/png)
2013-08-25 06:01 UTC, Maxim Monastirsky
Details
screenshot of test.odp in LO4.1.1.2 on OSX 10.8.4 (293.30 KB, image/jpeg)
2013-08-25 09:02 UTC, Theo
Details
test-case (9.29 KB, application/vnd.oasis.opendocument.presentation)
2013-08-28 05:07 UTC, Maxim Monastirsky
Details
screenshot of 4.1.1.2 (correct) (64.58 KB, image/png)
2013-08-28 05:09 UTC, Maxim Monastirsky
Details
screenshot of 4.0.5.2 (wrong) (69.06 KB, image/png)
2013-08-28 05:10 UTC, Maxim Monastirsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Theo 2013-08-22 13:06:25 UTC
Presentation fonts look OK In LO4.1.1, but when the saved file is opened in AO or older versions of LO 4.0.x or older default to Times New Roman. This is a major issue for corporate use.
Comment 1 Maxim Monastirsky 2013-08-22 19:15:59 UTC
Hi,
I can't reproduce this. Could you please attach a test document? Thanks.
Comment 2 Theo 2013-08-23 05:48:36 UTC
Created attachment 84497 [details]
test.odp

Test prez. Fonts display as DejaVu Sans in LO4.1.1.1, Times New Roman in LO4.0.5.1 and AO4.0.0
Comment 3 Maxim Monastirsky 2013-08-25 06:01:52 UTC
Created attachment 84581 [details]
screenshot of 4.1.1.1 on Windows 7 (32-bit)

@Theo: The presentation you attached opens with 'Times New Roman' also with 4.1.1.1 (see screenshot). Verified on Windows 7 (32-bit). Are you sure that 'Dejavu Sans' was used? Could you please attach a screenshot of the presentation in 4.1.1.1?
Comment 4 Theo 2013-08-25 09:02:21 UTC
Created attachment 84583 [details]
screenshot of test.odp in LO4.1.1.2 on OSX 10.8.4

Screenshot of test.odp in LO4.1.1.2 on MacOS. On Win 8 with LO4.1.1.1 I was getting the same result. It may have something to do with whether or not the template on which this presentation is based is installed.
Comment 5 Theo 2013-08-25 09:03:28 UTC
The problem manifests itself also in a different way: old presentations with DejaVu Sans font that have been edited in LO4.1.1.1 display Times Roman in older versions of LO and in AO4.0.
Comment 6 Maxim Monastirsky 2013-08-27 13:23:44 UTC
@Theo: Could you please take a look at Bug 67665? I think it's the same issue you have. If this is the case, please mark this bug as a duplicate. thanks.

(The fix for Bug 67665 is part of LO 4.1.1.2, so you can test it.)
Comment 7 Theo 2013-08-27 16:09:03 UTC
Bug 67665 looks to be related, but this problem is different. The problem is that the file looks fine in LO4.1.1.x, but not in older versions, nor in AO4.0.

Also existing presentations, updated in saved in LO4.1.1.2 show the problem: styles do not seem to be applied anymore when opening the doc in LO4.0.x or AO4.0.

Second point is that I have already checked LO4.1.1.2, but the problem is still there.
Comment 8 Maxim Monastirsky 2013-08-28 05:06:06 UTC
OK, I've managed to reproduce the bug. Here is how:
1) Open Impress\Draw 4.1.1.2
2) Add a textbox or a shape, and enter some text into it.
3) Edit the style of the text, by choosing other font
4) Save
5) Close the file & reopen. The file will open correctly (because Bug 67665 is fixed).
5) Open in LO 4.0.x, the font resets to default.

@Theo: test.odp isn't a valid test-case, since it was saved in 4.0.5 (You can see it if you unzip it and look into meta.xml), so marking it as obsolete.
Comment 9 Maxim Monastirsky 2013-08-28 05:07:50 UTC
Created attachment 84763 [details]
test-case
Comment 10 Maxim Monastirsky 2013-08-28 05:09:38 UTC
Created attachment 84764 [details]
screenshot of 4.1.1.2 (correct)
Comment 11 Maxim Monastirsky 2013-08-28 05:10:06 UTC
Created attachment 84766 [details]
screenshot of 4.0.5.2 (wrong)
Comment 12 Caolán McNamara 2013-09-04 12:13:32 UTC
It appears that older versions don't understand style:font-name in non-automatic styles, only the deprecated fo:font-family
Comment 13 Caolán McNamara 2013-09-04 14:40:00 UTC
Well, https://gerrit.libreoffice.org/#/c/5810/ works for me, i.e. default continue to filter out the fo:family-name in preference to style:font-name except for exporting non auto styles where we would now add both.
Comment 14 Commit Notification 2013-09-17 19:29:15 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d87cb77b42b591b1333aacd60e107514d6e20864

Resolves: fdo#68431 style:font-name unknown in non autostyles in impress/draw



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2013-09-19 15:41:10 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc46c86f56e0573d13d6b8140ef1aaf6f0db7895&h=libreoffice-4-1

Resolves: fdo#68431 style:font-name unknown in non autostyles in impress/draw


It will be available in LibreOffice 4.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Caolán McNamara 2013-09-19 15:59:49 UTC
fixed by all this I hope. Also proposed for 4.1.2 in gerrit
Comment 17 Maxim Monastirsky 2013-10-25 08:11:01 UTC
*** Bug 70855 has been marked as a duplicate of this bug. ***