Bug 68443 - Other: Incorrect widget rendering with oxygen-gtk in LibreOffice 4.0 and higher
Summary: Other: Incorrect widget rendering with oxygen-gtk in LibreOffice 4.0 and higher
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-08-22 16:56 UTC by S. Christian Collins
Modified: 2013-11-26 16:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot comparing LibreOffice 3.6.6.2 (left) and 4.1.0.4 (right) (403.12 KB, image/png)
2013-08-22 16:56 UTC, S. Christian Collins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S. Christian Collins 2013-08-22 16:56:35 UTC
Created attachment 84466 [details]
screenshot comparing LibreOffice 3.6.6.2 (left) and 4.1.0.4 (right)

Problem description: In LibreOffice 4.0 and higher, certain widgets are rendered incorrectly when using the oxygen-gtk theme. This was not a problem with LibreOffice 3.6. The attached screenshot shows a comparison of LibreOffice 3.6.6.2 (left) with LibreOffice 4.1.0.4 (right). The rendering issues in LibreOffice 4.0 include: . The font name and size dropdown boxes look messed up. . The scrollbar is misaligned, and the scrollbar buttons at the bottom are incorrect. . Many text input boxes have the text too close to the left edge of the input box (see font name, text style, etc.).
Operating System: Ubuntu
Version: 4.0.0.3 release
Last worked in: 3.6.6.2 release
Comment 1 S. Christian Collins 2013-08-22 16:59:05 UTC
I should also mention, this is using the latest version of oxygen-gtk (v1.3.4).
Comment 2 pieter kristensen 2013-08-31 09:45:03 UTC
I have exactly the same experience.

What I miss by far the most is a (thin) horizontal line between the toolbar and the editing area. It just look a little blurry without this line.
Comment 3 Maxim Monastirsky 2013-09-09 16:39:38 UTC
Reproducible with LO 4.1.1.2 under both Fedora 19 & Ubuntu 13.10.
Comment 4 Maxim Monastirsky 2013-09-09 16:54:53 UTC
The scrollbar problem has a seperate report at Bug 66829, and It seems to be already fixed in 4.1.1.2.
Comment 5 Maxim Monastirsky 2013-11-26 16:08:19 UTC
Fixed by upgrading oxygen-gtk2 to 1.4.0. Verified with Fedora 19 64-bit (which has it in repositories), and Ubuntu 13.04 64-bit. So looks like it was not LibreOffice bug, but a bug of oxygen-gtk2. Anyway it's fixed.