Download it now!
Bug 68465 - EDITING: Paste into search box puts pasted text into spreadsheet instead
Summary: EDITING: Paste into search box puts pasted text into spreadsheet instead
Status: RESOLVED DUPLICATE of bug 49853
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-23 06:20 UTC by Ralph Martin
Modified: 2013-08-24 10:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot as per request (275.36 KB, image/jpeg)
2013-08-23 14:55 UTC, Ralph Martin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Martin 2013-08-23 06:20:37 UTC
Pasting while the search box at the foot of the document is selected results in text incorrectly being pasted into the spreadsheet instead.

Steps to reproduce:
Select the search box at the foot of the document
Paste (using the menu OR command-V)


Current behavior:
Text incorrectly gets pasted into the spreadsheet itself in the last used cell

Expected behavior:
Text should get pasted into the search box, if the search box has been selected

It is clear that the target of typing, and the target of pasting should ALWAYS be the same.

This bug may have been present in earlier versions too.
              
Operating System: Mac OS X
Version: 4.1.0.4 release
Comment 1 tommy27 2013-08-23 14:45:44 UTC
which search box at the foot of document are you talking about?
could you please provide a screenshot?
Comment 2 Ralph Martin 2013-08-23 14:55:12 UTC
Created attachment 84522 [details]
Screen shot as per request
Comment 3 Ralph Martin 2013-08-23 14:57:06 UTC
See the bottom of the screen shot. I mean the place where you type the text to be found when doing a search.
Comment 4 Ralph Martin 2013-08-23 15:02:23 UTC
To be perfectly clear - if you click inside that box, and type, text appears in the box as expected.

If you click in that box and do paste (via menu or command V), the text does not go in that box as expected, but in whichever spreadsheet cell was last used.

Clicking in the box should move the focus from the cell to the search box, but while it seems to do so for typing, it does not do so for pasting. 

(It seems bizarre to me that the design could let these depend on two different notions of focus - but there you go).
Comment 5 tommy27 2013-08-23 15:17:41 UTC
Ok, You mean the Findbar (which is toggled by Ctrl+F)

I tested 4.1.0.4 under Win7 64bit and I can paste any text string inside the Findbar textbox without reproducing your bug.

I mean:
1- open new Calc file
2- digit "test" in A1 cell
3- copy text string
4- paste it into Findbar textbox
5- text correctly pasted in proper location

is that a MacOS specific bug?

moreover when you say "This bug may have been present in earlier versions too" have you ever effectively saw that bug before?
Comment 6 Ralph Martin 2013-08-23 15:20:18 UTC
It may well be a Mac specific bug. I don't have a Windows box or Linux box to test it on. I have noticed it on more than one Mac.

I am pretty sure the bug has been there a while. I think I have encountered it at odd times in the past, but have been too busy at the time to report it.

So, I believe it to be longstanding and not recently introduced.
Comment 7 ign_christian 2013-08-24 10:11:08 UTC
Hi Ralph, it's an already known old bug in Mac. Please comment in the previously reported bug instead.

*** This bug has been marked as a duplicate of bug 49853 ***