Download it now!
Bug 68466 - VIEWING: Cannot change text color using the hidden button
Summary: VIEWING: Cannot change text color using the hidden button
Status: RESOLVED DUPLICATE of bug 42029
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.3 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-23 07:34 UTC by sh.yaron@gmail.com
Modified: 2014-05-15 14:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sh.yaron@gmail.com 2013-08-23 07:34:26 UTC
Problem description: 
Text color (and text background color) cannot be changed when buttons appear outside the toolbar (when you click the >> button).


Steps to reproduce:
1. Move the text change color button so it'll appear when you click the >> button.
2. Click it
3. It will only change the color to the color previously selected, no other options

Current behavior:
Changes color to the previously selected one.


Expected behavior:
Let the user choose the desired color.
              
Operating System: Ubuntu
Version: 4.1.0.3 rc
Comment 1 Jean-Baptiste Faure 2013-09-22 08:38:08 UTC
I have seen this bug but I can't reproduce it anymore with the current state of 4.1 branch (LO 4.1.3.0.0+ Build ID: 7e0676734319ad62d1ee2d762fa3f5de71ee9a0)

Please, could you upgrade your LO version to the current RC for 4.1 (LO 4.1.2.2 which is available on the pre-release webpage: http://www.libreoffice.org/download/pre-releases/) and try again?

Best regards. JBF
Comment 2 Lior Kaplan 2013-09-25 08:24:30 UTC
Verified on a build from master 24/9 (SHA1 079779c9244867cfcfb059ba57715af18b3a5bfc).
Comment 3 Lior Kaplan 2013-09-25 15:10:18 UTC
(In reply to comment #2)
> Verified on a build from master 24/9 (SHA1
> 079779c9244867cfcfb059ba57715af18b3a5bfc).

Verified = reproduced the bug on master.
Comment 4 Jean-Baptiste Faure 2013-09-25 15:51:54 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Verified on a build from master 24/9 (SHA1
> > 079779c9244867cfcfb059ba57715af18b3a5bfc).
> 
> Verified = reproduced the bug on master.

Indeed, I have the same bug on my build of the master. It seems that, when hidden, this button functions the same way the paintbrush button.

Best regards. JBF
Comment 5 sh.yaron@gmail.com 2013-09-25 15:53:58 UTC
BTW Reproduced on Windows 7 with 4.0.1
Comment 6 Maxim Monastirsky 2014-05-15 14:45:28 UTC

*** This bug has been marked as a duplicate of bug 42029 ***