Bug Hunting Session
Bug 68508 - Sidebar visibly switches units when loading
Summary: Sidebar visibly switches units when loading
Status: RESOLVED DUPLICATE of bug 68806
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-24 14:41 UTC by Mihkel Tõnnov
Modified: 2015-05-30 12:38 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mihkel Tõnnov 2013-08-24 14:41:10 UTC
I have centimeters set as units in settings, however sidebar doesn't seem to remember it.

In Writer, if sidebar shows e.g. Styles & Formatting pane at first, and I then switch it to show the Properties pane, then the units for spacing and indent boxes are " (inches) for half a second and then switch to "cm". If the numeric value is not 0, then that is converted, too, although the result is a bit off, compared to Format - Paragraph dialog: if I set e.g. 0.55 cm space below paragraph via Format - Paragraph, and then switch sidebar to Properties pane, it shows first 0.00", then 0.22" and then 0.56 cm.

In addition, paragraph fill colour switches from blue to none on the sidebar (no paragrah fill colour is set).

In Calc, the text rotation box and cell background colour misbehave in a similar way.

I'm using 4.1.1.2 .deb-files from TDF, but this behaviour is also visible in 4.1.0.0.beta2 and most likely already earlier. Windows is affected, too.
Comment 1 Owen Genat (retired) 2013-11-13 10:51:17 UTC
I think the title of this bug could be altered from "visibly switches units from inches to cm" to "visibly switches units when loading" as millimeters, centimeters, picas, and points are all affected. I see the same thing here under Crunchbang 11 linux running v4.1.3.2.
Comment 2 Mihkel Tõnnov 2013-11-13 11:00:35 UTC
(In reply to comment #1)
> I think the title of this bug could be altered from "visibly switches units
> from inches to cm" to "visibly switches units when loading" as millimeters,
> centimeters, picas, and points are all affected.

Good point, done.
Comment 3 Mihkel Tõnnov 2014-01-08 22:52:09 UTC
Ugh, matters have gone worse with 4.2 -- now the numbers are wrong, too. Example: I have a paragraph with 0.42 cm spacing above it and 0.21 cm below it. Whenever activated, the Properties pane on the sidebar still visibly switches units, but now, it settles for a 10.00 cm for both of the spacing fields. Only when I select another paragraph, it comes to its senses.
Comment 4 Maxim Monastirsky 2014-11-26 21:19:20 UTC

*** This bug has been marked as a duplicate of bug 68806 ***