Bug 68526 - Notes field doesn't scroll up on slide change
Summary: Notes field doesn't scroll up on slide change
Status: RESOLVED FIXED
Alias: None
Product: Impress Remote
Classification: Unclassified
Component: Android Remote App (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-25 13:25 UTC by Christoph Fischer
Modified: 2015-02-13 19:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test document (13.06 KB, application/vnd.oasis.opendocument.presentation)
2013-12-14 11:55 UTC, Christoph Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Fischer 2013-08-25 13:25:02 UTC
When a slide has lots of notes attached an the user scrolls down in the notes field, switching to the next slide will leave the notes field scrolled down. In the worst case, if the this next slide only has a few lines of notes, it will even appear as if there were no notes at all, because the notes field is scrolled down to an empty space.

Changing slides always should rewind the notes field's position to the first line of the text.
Comment 1 Jean-Baptiste Faure 2013-12-14 11:17:08 UTC
Please, attach a test document and explain step by step how to reproduce the problem. Without detailed informations it is not possible to do further investigations.

Best regards. JBF
Comment 2 Christoph Fischer 2013-12-14 11:55:56 UTC
Created attachment 90767 [details]
Test document
Comment 3 Christoph Fischer 2013-12-14 11:58:27 UTC
Steps to reproduce this bug:

1. Open the test document.
2. Connect with the Android remote. You should see the notes for slide 1 there.
3. On your android device, scroll down all the way to the end of slide 1 notes.
4. On your android device, click on slide 2.
5. On your android device, you should now see slide 2, but an empty notes section. The notes are there, as you will see when you scroll up in the notes field.

The problem is that the notes field stays scrolled down from viewing slide 1, instead of scrolling back up to the beginning when you change the slide. The current implementation of scrolling on Android does not give any visual indication of this, making the notes field simply appear empty.
Comment 4 Christian Lohmaier 2013-12-16 14:02:58 UTC
This is fixed in the rewrite. (expect an update along with the 4.2.0 release, i.e. end of January)

http://cgit.freedesktop.org/libreoffice/core/commit/?id=06b632f0d367178b7266e50c6f140ef36984733f
Comment 5 Christoph Fischer 2013-12-16 14:14:49 UTC
Very cool!

Is there a chance that the rewrite would also cover bug #68528?
Comment 6 Robinson Tryon (qubit) 2015-02-13 19:40:30 UTC
Moving bug to (new) 'Impress Remote' product.