Bug 68555 - UI: Inconsistent Position of OK Button [ANNOYING!]
Summary: UI: Inconsistent Position of OK Button [ANNOYING!]
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.2.0 target:4.1.2
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-26 06:18 UTC by Kumāra
Modified: 2013-08-27 10:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Text Import dialog box in Calc (23.63 KB, image/png)
2013-08-27 06:52 UTC, Kumāra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kumāra 2013-08-26 06:18:33 UTC
It's annoying to click on a button that my mind has been programmed to think it's the OK button, then the Help window pops up!

Then I've to close the unwanted window, see where the OK button really is, and click again.

I think somebody recently moved the buttons, since I've encountered this dialog box many times before and never faced this problem till now.

When an LO dialog box has its buttons at the bottom, the OK button is universally on the left most, EXCEPT for the Text Import dialog box, where it is on right most.

To activate that dialog box,

1. Copy a few lines of text, e.g.:
ch.june@yaaho.com
lam88@yaaho.com
keow@yaaho.com
[not real addresses]

2. Paste (Ctrl-V) on an empty cell in Calc.

Notice the position of boxes below, and compare them with other dialog boxes.
Comment 1 Emir Sarı (away) 2013-08-26 07:11:27 UTC
Could not reproduce the issue myself on the latest master, but;

Caolan, adding you to CC, maybe you have info about the matter. 

Kumāra, could you give more info about how to get that dialog box again? Or a screenshot would be useful. Thanks in advance.
Comment 2 Kumāra 2013-08-27 06:52:19 UTC
Created attachment 84683 [details]
Text Import dialog box in Calc

Notice the order of buttons at the bottom, and compared with other dialog boxes with OK and Help.
Comment 3 Kumāra 2013-08-27 06:52:37 UTC
(In reply to comment #1)
> Kumāra, could you give more info about how to get that dialog box again? Or
> a screenshot would be useful. Thanks in advance.

I'm not sure what I need to do to improve on the instruction I gave. Anyway, I provide a screenshot of it.
Comment 4 Caolán McNamara 2013-08-27 09:41:03 UTC
yeah, I plan to eventually follow the platform order for these buttons, but for now they should still follow the same ordering as the pre-layout convention. I think this one went awry when it was converted from vertical ok/help/cancel buttons to horizontal ones.
Comment 5 Commit Notification 2013-08-27 09:47:18 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9d8cda2f54adc0af4abdc1fc9675e7bc9c94228c

Resolves: fdo#68555 use (current) consistent ok/cancel/help button order



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-08-27 10:18:13 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f9f0f27d1a8556e283050e01e8ddbdc125b11ae4&h=libreoffice-4-1

Resolves: fdo#68555 use (current) consistent ok/cancel/help button order


It will be available in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Kumāra 2013-08-27 10:22:31 UTC
(In reply to comment #4)
> yeah, I plan to eventually follow the platform order for these buttons, but
> for now they should still follow the same ordering as the pre-layout
> convention. I think this one went awry when it was converted from vertical
> ok/help/cancel buttons to horizontal ones.

Ah... So, this order is only for Windows version. Let me correct that.

Thought I'd have to be patient with this till then, thank you very much for picking this up,
Comment 8 Caolán McNamara 2013-08-27 10:25:19 UTC
btw these sort of things are super easy to fix these days, just fire up glade and edit the relevant .ui