Download it now!
Bug 68590 - LibreOffice Completely Corrupts Outline Style Generated in MS Office
Summary: LibreOffice Completely Corrupts Outline Style Generated in MS Office
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2013-08-27 03:58 UTC by Joel Madero
Modified: 2016-10-23 11:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Document Showing Problem (18.50 KB, application/msword)
2013-08-27 03:58 UTC, Joel Madero
Details
Shows Promote Button (136.99 KB, image/png)
2013-08-27 13:11 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2013-08-27 03:58:01 UTC
Created attachment 84677 [details]
Document Showing Problem

Hi All,

Attached: Test case created by my professor - I have multiple documents that have the same issue. As for creating from scratch - honestly not sure how she made them. I spoke with her after class and she did admit they were created using "multiple versions of Microsoft Office". Also as a release - she gave permission for me to make her document public :)

I have verified that they work no problem in Microsoft Office 2010

Steps to Reproduce:
1. Open attached document


Immediately notice that formatting is off compared to Microsoft Office (I'll attach a pdf to show what it looks like in MS Office)


2. Left click at end of line saying "I. Introduction to the Lawyer’s Role"

3. Push enter

Observed:
Formatting is completely messed up, fixing it is either incredibly tedious or almost impossible

Expected: Outline style should be maintained

Furthermore:

Try to undo - nothing happens

&

If you start "promoting" the level of the line (by either using the button on bottom of LibreOffice or using tab + enter at beginning of line) the entire style gets changed from "Default Style" to heading styles, becoming bolded and more. Plus if you undo at this stage the entire document becomes corrupted


Marking as:
Critical - completely breaks document making it unusable + you can't even undo the screw ups
High - usually highest but marking as High as I don't know how to reproduce this from a blank document so not sure how many people could potentially be affected

Major may be appropriate - I'll let an unbiased person make that call as this makes using LibreOffice for school incredibly painful for me :-/
Comment 1 Joel Madero 2013-08-27 03:59:33 UTC
Being in QA gives me a little leeway to ping you guys. Can someone confirm this one and give your feedback about priority......I was just in the process of promoting LibreOffice and FLOSS when I unfortunately stumbled on this nasty one

Thanks all
Comment 2 Thomas van der Meulen 2013-08-27 06:01:31 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice.
Version: 4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903 on Mac osx 10.8.4. 

Opening the file looks 4.1.1.2 but not in Version 4.0.5.2 (Build ID: 5464147a081647a250913f19c0715bca595af2f)... the first 3 lines are moved. 

I could reproduce step 3 and that undoing does nothing.


I haven't tested the "promoting" thing because I didn't understand it. 
Maybe some one els can test this?
Comment 3 Joel Madero 2013-08-27 13:11:59 UTC
Created attachment 84710 [details]
Shows Promote Button
Comment 4 Joel Madero 2013-08-27 13:12:50 UTC
Added an image showing the promote button so you can see what I'm talking about.

Thanks Thomas :) 

Thoughts on my priority
Comment 5 Joel Madero 2013-08-27 13:45:13 UTC
@Michael Stahl - usually I would refrain from cc'ing one of you devs on my own bug but I do really think this is a nasty one so, apologies for the noise if you disagree :)
Comment 6 Thomas van der Meulen 2013-08-27 13:45:57 UTC
Thank you Joel for explaining the promoting option. I can reproduce that as well. 

The bug doesn't include a crash or data loss so I think that major is a better priority.

see:
https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 7 Joel Madero 2013-08-27 13:46:22 UTC
and...removing Joren, Qubit and Florian from this one as Thomas confirmed quickly ;) No need for them to keep getting emails about it
Comment 8 Joel Madero 2013-08-27 13:46:38 UTC
@Thomas - good point ;) Thanks for the confirmation
Comment 9 Joel Madero 2013-08-27 13:47:35 UTC
sorry for blasting with noise - promise last one - I would argue that the complete obliteration of outline style is "loss of data" ;) But I'll leave it as major :)
Comment 10 Albrecht Müller 2014-08-28 16:49:55 UTC
While looking for a solution to another problem (see bug 83204) I run into this problem and could reproduce step 3 in the description using LO Writer Version 4.2.5.2/Windows 7.

I observed a few differences to the original description: Undo now removes the new paragraph. The wrong outline level that was introduced when the new paragraph was created persists and cannot be undone. I could repair this using the promote level button without messing up the rest of the document. So less data get lost, but a loss of data is still there.
Comment 11 QA Administrators 2015-09-04 02:49:33 UTC Comment hidden (obsolete)
Comment 12 Albrecht Müller 2015-09-04 18:50:19 UTC
Tried "Document Showing Problem" with LibreOffice Version: 4.4.4.3
Build-ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Gebietsschema: de_DE

Seemed to work: Hitting "Enter" at end of paragraph "I. Intro ... " gives an new paragraph "II.", the following paragraph is renumbered to "III.". Undo reverts the changes. Promoting and demoting seems to work as expected.

The document looks different if shown in MS Word, however. MS Word shows all numbering aligned at the left border and left margins are handled differently. This may be due to the fact that it's a Word 97 version which is a pretty old one.
Comment 13 Julien Nabet 2015-12-29 11:35:32 UTC
On pc Debian x86-64 with LO Debian package 5.0.4.2, I confirm Undo is ok.
About layout, I don't know since I don't have MsWord to test.

Joel: could you give an update with a recent LO version?
Comment 14 Joel Madero 2015-12-29 16:14:24 UTC
Seems fixed on 5.0.3 :)

Thanks!