Download it now!
Bug 83204 - FORMATTING: Import from rtf file ignores outline header formats
Summary: FORMATTING: Import from rtf file ignores outline header formats
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:4.4.0
Keywords: filter:rtf, notBibisectable, regression
: 65824 (view as bug list)
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2014-08-28 16:29 UTC by Albrecht Müller
Modified: 2016-10-23 11:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file to show the effect. (10.67 KB, application/rtf)
2014-08-28 16:29 UTC, Albrecht Müller
Details
LibO 3.3.0 vs Master (90.70 KB, image/png)
2014-08-31 14:33 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albrecht Müller 2014-08-28 16:29:25 UTC
Created attachment 105391 [details]
Example file to show the effect.

The attached rtf file is a documentation report created using the Enterprise Architect UML tool. It is the documentation of a dummy project. This project contains a couple of nested, empty packages. Therefore the documentation consists of an outline only. The structure of the outline reflects the nesting of the packages.

How to reproduce the error:
Open the attached file with LibreOffice Writer. You should see a document containing a couple of blue lines, containing the text "Title" or "Header (xxx)", where xxx is an outline numbering.

Current behaviour: All the blue lines use the same paragraph style, the "Default Style".

Expected behaviour: The blue lines should use a heading paragraph style corresponding to the outline numbering.

The rtf file is interpreted correctly by MS Word 97 on Windows XP and MS Word 2010 on Windows 8.

The problem is a regression, as an old StarOffice 9 installation shows the correct paragraph styles.

Observed with LibreOffice 4.2.5.2 and Windows 7.
Comment 1 Yousuf Philips (jay) (retired) 2014-08-31 14:32:14 UTC
Hello Albrecht,

Thank you for submitting the bug. I can confirm that the bug wasnt there in 3.3.0 (old RTF import filter) and is there in master (new RTF importer).

Version: 4.4.0.0.alpha0+
Build ID: fcc6e8ae56d539ef92bfb917a52ac0638b3db25f
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-08-30_01:50:29
Comment 2 Yousuf Philips (jay) (retired) 2014-08-31 14:33:50 UTC
Created attachment 105487 [details]
LibO 3.3.0 vs Master
Comment 3 Björn Michaelsen 2014-10-14 00:41:48 UTC
Why is this marked notBibisectable?
Comment 4 Yousuf Philips (jay) (retired) 2014-10-14 07:25:27 UTC
(In reply to Björn Michaelsen from comment #3)
> Why is this marked notBibisectable?

I set it as notBibisectable as its a bug pre-3.6 and is a regression because of Miklos' new rtf import code caused the regression. Was i wrong about this?
Comment 5 Miklos Vajna 2014-11-13 22:15:00 UTC
Problem is that {\*\bkmkstart ...}\pard<para props> sequence is not handled, i.e. we expect that by the time some text shows up in a paragraph (where a bookmark name counts as "some text") paragraph properties are finalized. I'll look into this.
Comment 6 Commit Notification 2014-11-16 11:38:12 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a30ba573470d59dbb0501b488f8a655b015ffd2

fdo#83204 RTF import: handle \pard<para props> after \bkmkstart

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Miklos Vajna 2014-11-18 09:10:06 UTC
libreoffice-4-3 review: https://gerrit.libreoffice.org/12527
Comment 8 Marina Latini (CIB) 2015-01-15 14:36:24 UTC
Verified on:

* Version: 4.5.0.0.alpha0+
* Build ID: 84c69550bcb8139669de9cf98b51c35f21fe853d
* TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-13_08:44:23
* Locale: it_IT

on Ubuntu 14.04.1 LTS x86_64 with fresh user profile
Comment 9 Miklos Vajna 2015-04-04 10:12:05 UTC
*** Bug 65824 has been marked as a duplicate of this bug. ***
Comment 10 Robinson Tryon (qubit) 2015-12-17 11:11:15 UTC Comment hidden (obsolete)