Bug Hunting Session
Bug 65824 - RTF rendering issue related to bookmarks
Summary: RTF rendering issue related to bookmarks
Status: RESOLVED DUPLICATE of bug 83204
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta0
Hardware: All Linux (All)
: low normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-16 13:25 UTC by omega
Modified: 2015-04-04 10:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF file to reproduce the problem plus visualization (23.50 KB, application/zip)
2013-06-16 13:25 UTC, omega
Details

Note You need to log in before you can comment on or make changes to this bug.
Description omega 2013-06-16 13:25:22 UTC
Created attachment 80909 [details]
RTF file to reproduce the problem plus visualization

Dear all,

the attached RTF file TEST.RTF is not rendered correctly if the line

{\*\bkmkstart ThisCausesTheProblem}{\*\bkmkend ThisCausesTheProblem}

is in. 

Please have a look at the parts that begin with {\pard\s5 ... (style 5). You see several such formatted blocks, one prefixed with the number 2 and another prefixed with the number 3. 

If the first block is preceded by the bookmark, the alignment of the number 2 (right aligned) is wrong and the upcoming text ("Lorem ipsum...") is skewed [please see attached "test (wrong).pdf"]. If you remove the line with the bookmark from the RTF file, everything is as intended [please see attached "test (correct).pdf"].

This used to work in previous versions of OpenOffice (at least up to 2011 or so).

I spent some time stripping the RTF file down to a reasonable minimum to identify the cause of the issue. I would be glad if this was sufficient to find the cause and fix it. I will be glad to help you investigating the issue further.

Kind regards,
Boris
Comment 1 Joel Madero 2013-06-20 19:07:18 UTC
Thank you for reporting this issue! I have been able to confirm the issue with the earliest version of bibisect:
Version 3.5.0 beta0 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Normal - can prevent high quality work
Low - only occurring under specific situations with a format which isn't widely used in the community (vs. odt, doc, docx)

CC'ing expert to get additional input/ask if he wants to accept the bug :)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Miklos Vajna 2015-04-04 10:12:05 UTC
I'm sorry, I did not notice this in time. This is the same problem as bug 83204, fixed by commit 8a30ba573470d59dbb0501b488f8a655b015ffd2 (fdo#83204 RTF import: handle \pard<para props> after \bkmkstart, 2014-11-16). Given that it's already marked as resolved, I'm marking this as the duplicate, though I realize that ideally that other one would have to be marked as the duplicate of this bug. :-)

*** This bug has been marked as a duplicate of bug 83204 ***