Bug Hunting Session
Bug 68623 - Feature Request: Paste At Mouse Position
Summary: Feature Request: Paste At Mouse Position
Status: RESOLVED DUPLICATE of bug 86600
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-27 18:25 UTC by Dave Richards
Modified: 2016-06-30 15:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Richards 2013-08-27 18:25:19 UTC
When you have something in the clipboard, object or image it would be very helpful if the object would paste at the current mouse position when you right-mouse click.    Right now, if the edit > copy item is existing in the document the paste goes to the same spot.  If the copy item is external, it randomly picks a place to paste it.

The chances of wanting to paste an object on top of itself is rare, so it seems like this would be a logical feature.

If you used the pulldowns edit >paste obviously it would not be able to do this; this would only work when the paste is done from the right-mouse.
Comment 1 Jean-Baptiste Faure 2013-12-07 13:30:35 UTC
I agree. But I am afraid that it might not be as easy to implement than it is to describe.

Best regards. JBF
Comment 2 Gaétan RYCKEBOER 2016-05-18 08:46:49 UTC
I agree. It would be a good feature. It is awfully pervert to search at the bottom right end, way past the paper width, for pasted objects.

I dont even understand why LO Draw allows pasting of an object outside the border of the defined page.

It may be pasted inside the screen.
Comment 3 Heiko Tietze 2016-06-30 15:41:17 UTC

*** This bug has been marked as a duplicate of bug 86600 ***