Download it now!
Bug 68624 - FILEOPEN: Style formatting is lost after saving and reloading
Summary: FILEOPEN: Style formatting is lost after saving and reloading
Status: RESOLVED DUPLICATE of bug 67665
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-27 18:39 UTC by Federico Kereki
Modified: 2013-11-20 15:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
This is a presentation that includes a single box, in a user-defined format. (20.45 KB, application/vnd.oasis.opendocument.presentation)
2013-08-27 18:39 UTC, Federico Kereki
Details
This PDF shows the presentation as it looked, before saving and reloading. (14.37 KB, application/pdf)
2013-08-27 18:41 UTC, Federico Kereki
Details
This PDF shows the presentation after reloading -- the style definition is wrong. (30.42 KB, application/pdf)
2013-08-27 18:41 UTC, Federico Kereki
Details
This is the "Traveling_Typewriter" font, used in the example (83.60 KB, application/x-font-ttf)
2013-08-27 18:43 UTC, Federico Kereki
Details
This PDF shows the presentation as it looked, before saving and reloading. (14.37 KB, application/pdf)
2013-08-27 18:43 UTC, Federico Kereki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Kereki 2013-08-27 18:39:15 UTC
Created attachment 84741 [details]
This is a presentation that includes a single box, in a user-defined format.

I created a style, which uses a specific font. After saving a presentation that uses that style, when I reload the presentation, the style shows the wrong font. This happens at least with boxes (objects).

Steps to reproduce:
1. Create a box style using a different font, other than standard.
2. Use the style in a presentation
3. Save it
4. Close LibreOffice
5. Open LibreOffice again, and load the presentation
6. The box style will be back to standard.

Current behavior:
The font of the "PreguntaVerde" style changes from "Traveling_Typewriter" to the standard "Times New Roman".

Expected behavior:
The defined font ("Traveling_Typewriter", in this case) should be preserved.

              
Operating System: openSUSE
Version: 4.1.0.4 release
Comment 1 Federico Kereki 2013-08-27 18:41:04 UTC
Created attachment 84742 [details]
This PDF shows the presentation as it looked, before saving and reloading.
Comment 2 Federico Kereki 2013-08-27 18:41:34 UTC
Created attachment 84743 [details]
This PDF shows the presentation after reloading -- the style definition is wrong.
Comment 3 Federico Kereki 2013-08-27 18:43:06 UTC
Created attachment 84744 [details]
This is the "Traveling_Typewriter" font, used in the example
Comment 4 Federico Kereki 2013-08-27 18:43:56 UTC
Created attachment 84745 [details]
This PDF shows the presentation as it looked, before saving and reloading.
Comment 5 Federico Kereki 2013-08-27 18:46:15 UTC
Attachment 84742 [details] was uploaded with a wrong type; attachment 84745 [details] is correct.
Comment 6 Maxim Monastirsky 2013-08-27 19:04:21 UTC

*** This bug has been marked as a duplicate of bug 67665 ***