Bug 68647 - Other: Batch convert of --convert-to in terminal mode does not work
Summary: Other: Batch convert of --convert-to in terminal mode does not work
Status: RESOLVED DUPLICATE of bug 48413
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
(earliest affected) release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
: 89744 (view as bug list)
Depends on:
Reported: 2013-08-28 09:20 UTC by Wolf.Kuerschner
Modified: 2015-07-31 11:36 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Wolf.Kuerschner 2013-08-28 09:20:41 UTC
Problem description: 

soffice --headless --convert-to pdf *.odt does not produce output


soffice --headless --convert-to pdf test.odt does produce test.pdf

(on the same computer running Win XP Pro - German version)

Steps to reproduce:
1. Open terminal (Start-> cmd) and go to the folder with soffice
2. enter the statement from above

Current behavior:

no output produced, independent of the output file type (I tested different ones)

Expected behavior:

all *.odt file in the folder should be converted to .pdf files

Operating System: Windows XP
Version: release
Comment 1 Julien Nabet 2013-08-30 05:51:04 UTC
On pc Debian x86-64 with master sources updated today and with 4.1 sources updated some days ago, I didn't reproduce this problem.

I created 2 documents test1.odt and test2.odt when using "soffice --headless --convert-to pdf *.odt", I had 2 files. (test1.pdf and test2.pdf)

For the test, could you give a try to new LO version 4.1.1?
Comment 2 Wolf.Kuerschner 2013-09-02 12:53:06 UTC

I tested it on LO 3.6 and now on LO (two different PC, Win XP Pro 32), and as before: no PDFs created...
Comment 3 Wolf.Kuerschner 2013-09-02 13:08:43 UTC
maybe * is not recognized?
Comment 4 Julien Nabet 2013-09-02 16:45:32 UTC
Thank you Wolf for your feedback, I put it back to UNCONFIRMED since I don't have more questions.
BTW, "*" worked for me.
Comment 5 Wolf.Kuerschner 2013-09-03 09:25:13 UTC
yes, "*" works for me nicely in the command line, too. Except that it looks as if LO does not recognize it. If I just add several file names, all of them are converted to PDFs. Somehow LO is not capable to understand that *.odt has to be read as Test.odt, Test2.odt??
Comment 6 Julien Nabet 2013-09-03 18:14:09 UTC
Ok I reproduced this with LO 4.0.5 on Win7 but not on Linux. I suppose Windows only bug.
Since you reproduced this on 3.6, I put version to since version must contain the oldest version where the bug can be reproduced.
Comment 7 Julien Nabet 2013-09-03 18:17:55 UTC
Riccardo: one for you?
Comment 8 Riccardo Magliocchetti 2013-09-03 18:23:32 UTC
(In reply to comment #7)
> Riccardo: one for you?

The issue with --convert-to is that it use a different code path than what you are doing using unoconv. Unfortunately I have no clue / time to investigate that.
Comment 9 Julien Nabet 2013-09-03 20:25:21 UTC
Michael: do you know who may help here?
BTW, I tried a gdb session because I saw in the file desktop/source/app/app.cxx this
   2611     // Add path separator to these directory and make given URL (rName) absolute by using of current working directory
   2612     // Attention: "setFinalSlash()" is necessary for calling "smartRel2Abs()"!!!
   2613     // Otherwhise last part will be ignored and wrong result will be returned!!!
   2614     // "smartRel2Abs()" interpret given URL as file not as path. So he truncate last element to get the base path ...
   2615     // But if we add a separator - he doesn't do it anymore.
   2616     INetURLObject aObj;
(see http://opengrok.libreoffice.org/xref/core/desktop/source/app/app.cxx#2610)
I thought the problem might be there but I don't know how to display OUString or simple String (I gave a try to https://wiki.documentfoundation.org/Development/How_to_debug#Dumping_Strings_.28etc.29 but I didn't succeed in making gdb display anything useful)
Comment 10 Julien Nabet 2013-09-06 05:07:39 UTC
Michael: sorry for the noise about gdb printers, I had just to read the gdb warnings. I created ~/.gdbinit and added this line:
set auto-load safe-path /
Comment 11 QA Administrators 2015-04-01 14:42:42 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)


2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 12 Buovjaga 2015-04-24 17:23:47 UTC

Win 7 Pro 64-bit, Version:
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: fi_FI
Comment 13 Maxim Monastirsky 2015-07-31 11:14:34 UTC
*** Bug 89744 has been marked as a duplicate of this bug. ***
Comment 14 Maxim Monastirsky 2015-07-31 11:36:11 UTC
Most likely a duplicate by itself.

*** This bug has been marked as a duplicate of bug 48413 ***