Bug 68710 - FILESAVE DOC Tables corrupted when saving in Word97 format
Summary: FILESAVE DOC Tables corrupted when saving in Word97 format
Status: RESOLVED DUPLICATE of bug 61423
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:doc
Depends on:
Blocks: DOC-Corrupted DOC-Tables
  Show dependency treegraph
 
Reported: 2013-08-29 15:00 UTC by ThomasBourchier
Modified: 2020-04-17 13:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The zip contains the three files referred to in the bug report (61.48 KB, application/x-zip-compressed)
2013-08-29 15:00 UTC, ThomasBourchier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ThomasBourchier 2013-08-29 15:00:26 UTC
Created attachment 84849 [details]
The zip contains the three files referred to in the bug report

Problem description: A document was created in Writer that contains a couple of tables (see file two-tables.odt as attached). When I did "file/save as" in Word97 format, the resulting document (file word97.doc as attached) contained tables that MS Office 2007 described as corrupt and tried (unsuccessfully) to repair (see file word97-rep.doc).

If I open Word97.doc with Writer, the first table looks good. However the second table ends with some spurious page breaks.

If I export file two-tables.odt in PDF format, there are no problems.

Steps to reproduce:
1. Open file two-tables.odt in Writer
2. Choose "file/save as" and save in Word97 format
3. Now open the resulting file in Word 2007

Current behavior: The resulting Word97 format file has tables that Word 97 regards as corrupt, and that even Writer has some issues with.

Expected behavior: The Word97-format file should look the same as the original file in Writer, and should not be corrupt as far as Word is concerned.

              
Operating System: Windows 7
Version: 4.0.4.2 release
Comment 1 Thomas van der Meulen 2013-08-30 07:14:28 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice.
Version: 4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903 on Mac osx 10.8.4. 

I can see that the file is totally corrupted
Comment 2 QA Administrators 2015-04-01 14:41:57 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-04-24 11:05:58 UTC
Reproduced the page breaks when saving .odt to .doc.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI

OpenOffice.org 3.3.0
OOO330m20 (Build:9567)
Comment 4 QA Administrators 2016-09-20 09:32:35 UTC Comment hidden (obsolete)
Comment 5 Thomas Lendo 2018-10-17 20:38:15 UTC
Still reproducible.

Version: 6.2.0.0.alpha0+
Build ID: d92319d2ffeaa65e31f923e0e9c7328b8d7c97bf
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: threaded
from today
Comment 6 QA Administrators 2019-10-18 02:39:33 UTC Comment hidden (obsolete)
Comment 7 ThomasBourchier 2019-10-18 08:32:50 UTC
This bug is still present in LibreOffice 6.2.7.1. However, if you save the .odt file as a .docx file (Word 2007-2019) format then the tables look fine.

Given the antiquity of Word97, I am happy for this bug to be closed.
Comment 8 Buovjaga 2019-10-18 11:00:07 UTC
Well, it was recently decided that .PPT filesave bugs should be kept open, so let's keep this one as well.
Comment 9 Justin L 2020-04-17 11:35:57 UTC
As a side note, saving as DOCX saves page numbers as regular numbers, not roman numerals. That must be an import problem, because Word 2003 reads the docx with roman numerals. A regression in LO 6.0. Reported as bug 132185.

This appears to be a duplicate of bug 61423
Comment 10 Justin L 2020-04-17 13:22:13 UTC

*** This bug has been marked as a duplicate of bug 61423 ***