Bug 68715 - FILEOPEN RTF: Wrong alignment of numbers in a table with comma as thousands separator
Summary: FILEOPEN RTF: Wrong alignment of numbers in a table with comma as thousands s...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF-Tables
  Show dependency treegraph
 
Reported: 2013-08-29 17:03 UTC by Robert
Modified: 2020-05-16 16:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF document with formatting issues (52.97 KB, text/rtf)
2013-08-29 17:03 UTC, Robert
Details
comparison MSO 2010 and LibreOffice 6.3 Master (123.64 KB, image/png)
2019-05-16 10:06 UTC, Xisco Faulí
Details
Every amount with a comma is aligned wrongly! (257.56 KB, image/png)
2019-05-20 22:01 UTC, robert
Details
Result form MS Word 2016 (19.50 KB, application/pdf)
2019-11-18 09:02 UTC, Dieter
Details
Result from LO 6.4.0.0 (543.19 KB, application/pdf)
2019-11-18 09:02 UTC, Dieter
Details
Word 2002 with decimal tabs (285 bytes, application/msword)
2020-05-16 16:45 UTC, robert
Details
Word 2002 with decimal tabs - screenprint (66.54 KB, image/png)
2020-05-16 16:45 UTC, robert
Details
Saved one.word2002.rtf to .odt (9.28 KB, application/vnd.oasis.opendocument.text)
2020-05-16 16:46 UTC, robert
Details
Saved one.word2002.rtf to .odt - screenprint (110.06 KB, image/png)
2020-05-16 16:47 UTC, robert
Details
Saved one.word2002.rtf to .odt manual change of style (9.82 KB, application/vnd.oasis.opendocument.text)
2020-05-16 16:47 UTC, robert
Details
Saved one.word2002.rtf to .odt manual change of style - screenprint (96.02 KB, image/png)
2020-05-16 16:48 UTC, robert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2013-08-29 17:03:47 UTC
Created attachment 84867 [details]
RTF document with formatting issues

Although the RTF import is getting better, the attached document still has several problems:

- The "Jellyfish Shark Limited" heading at the top of all pages is not centered

- A number of table cell entries are not aligned on the decimal tabs, e.g. on page 6, in the row containing "Total assets less current liabilities" the 2012 and 2011 accounts are not aligned on the decimal tab (the tab seems to be missing completely) and in the row above the same is true for *only* the 2011 amount. The same thing happens to both amounts in the "Administration" row on page 10, while all other amounts in that table *are* correct.
Comment 1 Thomas van der Meulen 2013-08-30 07:04:22 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice.
Version: 4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903 on Mac osx 10.8.4.
Comment 2 Alexandr 2014-07-18 15:42:51 UTC
> - The "Jellyfish Shark Limited" heading at the top of all pages is not centered
Reproducible with LibreOffice 4.2.5 and 4.3.0 on Debian.

> - A number of table cell entries are not aligned on the decimal tabs, e.g. on > page 6, in the row containing "Total assets less current liabilities" the 2012 > and 2011 accounts are not aligned on the decimal tab (the tab seems to be 
> missing completely) and in the row above the same is true for *only* the 2011 > amount. The same thing happens to both amounts in the "Administration" row on > page 10, while all other amounts in that table *are* correct.

I can not reproduce. These lines seems to be aligned on the decimal tabs. Some other lines are not. Unfortunately, in MS Word Viewer more lines are not aligned on the decimal tabs. Is LibreOffice representation correct now? If not, could you provide a reference representation? Maybe comparative screenshot?
Comment 3 Alexandr 2014-07-18 16:25:48 UTC
Square brakets appear on page 10 in the text ducument in LibreOffice 4.3.0.3. I report it as bug 81502.
Comment 4 Robert 2014-07-30 07:58:27 UTC
Current (4.3.0.4) issues:

1) Square brackets appear in lots of places
2) Page headings are not centred
3) Formulas in tables still don't work
Comment 5 Alexandr 2014-07-30 09:33:55 UTC
> 1) Square brackets appear in lots of places

Michael Stahl has already fixed the issue with brackets (bug 81502). The patch will be available in LibreOffice 4.3.1 and 4.4.0.
Comment 6 QA Administrators 2015-09-04 02:49:45 UTC Comment hidden (obsolete)
Comment 7 robert 2015-09-04 06:58:52 UTC
Decimal tabs are still wrong!

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: en-GB (en_GB)

W7-64, fully patched.
Comment 8 Robinson Tryon (qubit) 2015-12-10 01:08:25 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2016-10-09 22:17:46 UTC
Decimal tabs look ok in

Version: 5.3.0.0.alpha0+
Build ID: ae3ec79354f7b4967e736c6a4cd7c08fc52e2b7d
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

thus, closing this as RESOLVED WORKSFORME
Comment 10 robert 2019-05-10 09:28:39 UTC
Problems with decimal tabs and formulae still occur with

Version: 6.2.3.2 (x64)
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded
Comment 11 Xisco Faulí 2019-05-16 10:06:53 UTC
Created attachment 151448 [details]
comparison MSO 2010 and LibreOffice 6.3 Master
Comment 12 Xisco Faulí 2019-05-16 10:08:03 UTC
(In reply to robert from comment #10)
> Problems with decimal tabs and formulae still occur with
> 
> Version: 6.2.3.2 (x64)
> Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
> CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
> Locale: en-GB (en_GB); UI-Language: en-US
> Calc: threaded

See attached image. I don't see any difference between LibreOffice and MSO 2010.
Please, add a screenshot of the problem you have with decimal tabs...
Comment 13 robert 2019-05-20 22:01:29 UTC
Created attachment 151541 [details]
Every amount with a comma is aligned wrongly!

Every amount containing a comma is aligned wrongly!
Comment 14 QA Administrators 2019-11-17 03:32:37 UTC Comment hidden (obsolete)
Comment 15 robert 2019-11-17 10:09:12 UTC
On 2019-05-20T22:01 a side-by-side screenprint of the same document opened in Word and LO wasattached. It VERY CLEARLY SHOWS THE PROBLEM.

And for what it's worth, formula's in tables still do not work either!

Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded
Comment 16 Dieter 2019-11-17 15:00:52 UTC
Robert, I can see difference in attachment from comment 13, but when I open the document from bug description in MS Word 2013, it looks the same as in LO 6.4.0.0.beta 1. What version of MS Word do you use?
Comment 17 robert 2019-11-17 16:51:10 UTC
Word 2002 (10.2627.2625), the freebie that came with my PC.
Comment 18 Dieter 2019-11-18 09:01:02 UTC
(In reply to robert from comment #17)
> Word 2002 (10.2627.2625), the freebie that came with my PC.

See results from LO an d Word 2016 in the following attachments. Do you see any difference? If not, can we close this bug?
Comment 19 Dieter 2019-11-18 09:02:03 UTC
Created attachment 155907 [details]
Result form MS Word 2016
Comment 20 Dieter 2019-11-18 09:02:58 UTC
Created attachment 155908 [details]
Result from LO 6.4.0.0
Comment 21 robert 2019-11-18 13:08:57 UTC
There are no differences, and that means both Word and LO fail to properly process the decimal tabs, and this means that BOTH are buggy.

Look at the flipping pages, the amounts are not, not, not properly aligned, and I don't really give a flying whatever that LO displays them the same way as some M$ product that isn't even compatible with itself, amounts that should be aligned on decimal tabs should be aligned on decimal tabs!

THIS IS A BUG, SO DO NOT CLOSE THIS REPORT!
Comment 22 Dieter 2020-05-13 07:46:22 UTC
I don't think, that it is a problem of decimal tabs, because it I replace comma with a dot, the numbers are in line. you can save it as rtf and reopen and it still looks fine. I think this is independent from localization (tested with German and UK Localization).

I've tried with number recognition enabled and different setting in Table => Number Format but wasn't successful.

Version: 7.0.0.0.alpha1+ (x64)
Build ID: 99c337d1d3831ce9d2c7dc1cbff713f4ac49d6ac
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

So I change status to new but change also bug summary, bacause Word shows the same wrong result.
Comment 23 robert 2020-05-14 13:33:53 UTC
(In reply to Dieter from comment #22)
> I don't think, that it is a problem of decimal tabs, because it I replace
> comma with a dot, the numbers are in line. you can save it as rtf and reopen
> and it still looks fine. I think this is independent from localization
> (tested with German and UK Localization).

That is exactly the problem. The UK uses a 9,999.99 format, Germany uses 9.999,99 format, and from the whole thread it should be obvious that something somewhere mixes up the locales vs decimal tabs!
Comment 24 Dieter 2020-05-14 14:18:25 UTC
(In reply to robert from comment #23)
> That is exactly the problem. The UK uses a 9,999.99 format, Germany uses
> 9.999,99 format, and from the whole thread it should be obvious that
> something somewhere mixes up the locales vs decimal tabs!

Do you know, if it works outside tables (I haven't tested).
Comment 25 robert 2020-05-16 16:43:54 UTC
Same results outside tables, which doesn't surprise me as the issue has nothing to do with tables.

See the attached six files, a RTF, two ODTs and three PNGs of the screen. Pasted the LO data to the ODT, and displayed the setting dialog. FWIW, in "one.6.4.3.2.odt" "content.xml" the styles contain

<style:style style:name="P1" style:family="paragraph" style:parent-style-name="Standard">
<style:paragraph-properties>
<style:tab-stops>
<style:tab-stop style:position="4.001cm" style:type="char" style:char=","/> </style:tab-stops>
</style:paragraph-properties>
</style:style>

Manually unzipping the ODT and replacing the "," with a "." still screws up the output - see the "one(dot).6.4.3.2.odt/png"
Comment 26 robert 2020-05-16 16:45:00 UTC
Created attachment 160899 [details]
Word 2002 with decimal tabs
Comment 27 robert 2020-05-16 16:45:48 UTC
Created attachment 160900 [details]
Word 2002 with decimal tabs - screenprint
Comment 28 robert 2020-05-16 16:46:33 UTC
Created attachment 160901 [details]
Saved one.word2002.rtf to .odt
Comment 29 robert 2020-05-16 16:47:15 UTC
Created attachment 160902 [details]
Saved one.word2002.rtf to .odt - screenprint
Comment 30 robert 2020-05-16 16:47:59 UTC
Created attachment 160903 [details]
Saved one.word2002.rtf to .odt manual change of style
Comment 31 robert 2020-05-16 16:48:36 UTC
Created attachment 160904 [details]
Saved one.word2002.rtf to .odt manual change of style - screenprint