Bug 68717 - EDITING: replacing in current selection only does not work
Summary: EDITING: replacing in current selection only does not work
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2013-08-29 17:38 UTC by kaesezeh
Modified: 2022-11-04 10:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Slideshow in which replacing doesn't work (12.49 KB, application/vnd.oasis.opendocument.presentation)
2013-08-29 17:38 UTC, kaesezeh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaesezeh 2013-08-29 17:38:19 UTC
Created attachment 84872 [details]
Slideshow in which replacing doesn't work

Using LO 4.1.0.4 on Linux Mint 15 64bit KDE. Here's the problem:

- load the attached document;
- select rows 2 and 3;
- CTRL-H
- Search for: " " (i.e. a space)
  Replace with: "_"
- Tick Other Options, then "Current selection only";
- Click Replace All.

On my system, it doesn't do any replacements but immediately says "The document search is finished."
Comment 1 ign_christian 2013-08-30 14:47:42 UTC
I can reproduce on LO 4.0.5.2 (Win7 32bit). 

Did short testing, looks like "current selection only" not working with any search & replace terms.
Comment 2 QA Administrators 2015-04-19 03:20:00 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-06-15 09:48:44 UTC
Still doesn't work.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)
Comment 5 QA Administrators 2016-09-20 10:00:39 UTC Comment hidden (obsolete)
Comment 6 Thomas Lendo 2019-06-23 20:35:23 UTC
Still not possible to select 'Current selection only' in search window.

Version: 6.3.0.0.beta1
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Comment 7 QA Administrators 2021-06-23 03:48:53 UTC
Dear kaesezeh,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug