Bug 68771 - Crash without warning launch on old OS X (10.5)
Summary: Crash without warning launch on old OS X (10.5)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-08-30 21:26 UTC by Steve Piercy
Modified: 2014-01-19 06:10 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
LO 4.1.1.2 rc crash log on Mac OS X 10.5.8 (2.43 KB, text/plain)
2013-09-02 07:59 UTC, Steve Piercy
Details
LO 4.1.1 crash log on Mac OS X 10.5.8 (765 bytes, text/plain)
2013-09-12 15:30 UTC, 894y14q
Details
Adium shows incompatible version before installing (112.25 KB, image/tiff)
2013-09-16 21:03 UTC, 894y14q
Details
lo and behold: LO shows incompatible version (517.27 KB, image/tiff)
2013-09-16 21:05 UTC, 894y14q
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Piercy 2013-08-30 21:26:31 UTC
Problem description: 
LO 4.1.0 crashes on launch on Mac OS X 10.5.8

Steps to reproduce:
1. Download, install, launch LO 4.1.0

Current behavior:
Crash

Expected behavior:
Not crash
Operating System: Mac OS X
Version: 4.1.0.4 release
Comment 1 tommy27 2013-08-31 13:46:36 UTC
I'm on Windows so I cannot test.
However try unistalling 4.1.0 and install new 4.1.1 that was released few days ago. do you still have problems?
Comment 2 Steve Piercy 2013-08-31 19:56:25 UTC
I downloaded and installed this yesterday:

http://www.libreoffice.org/download/?type=mac-x86&version=4.1.1&lang=en-US

I've corrected my bug report to reflect the proper version.

Side note: the UI to the bug tracker via libreoffice.org is very difficult to use and contributed to my data entry fumbling.
https://www.libreoffice.org/get-help/bug/

The select menus don't permit keyboard navigation and only display on a mouseover.  That's horrible UI!  I'm using the bug tracker on freedesktop.org directly now to avoid the issue.
Comment 3 tommy27 2013-08-31 20:02:33 UTC
(In reply to comment #2)
> I downloaded and installed this yesterday:
> 
> http://www.libreoffice.org/download/?type=mac-x86&version=4.1.1&lang=en-US
> 
> I've corrected my bug report to reflect the proper version.
> ... snip ...

Never change the version of the bug to a later version. The version field of the bug should always show the earliest version manifesting the bug. Please do not change a version, because it also manifests in a later version.

Reverting version to 4.1.0.4 release
Comment 4 Steve Piercy 2013-08-31 21:09:01 UTC
I never downloaded nor installed 4.1.0.4.  My original bug report was not correct.  If there is another bug report citing that 4.1.0.4 crashes on launch on Mac OS X, then that should be referenced in this report.

The crash on launch occurs with 4.1.1.2 rc.  Re-reverting to correct version in the bug tracker.
Comment 5 retired 2013-09-01 10:25:05 UTC
Steve, any chance you can update your OS?

Using OS X 10.8.4 I can not reproduce this problem. So might be related to OS X (which is a very old OS btw).
Comment 6 Steve Piercy 2013-09-01 10:41:33 UTC
(In reply to comment #5)
> Steve, any chance you can update your OS?

Nope.  I still need to use creaky, rusty, old 10.5.8 for certain apps.  I have LO 4.0.5.2 installed and working on that Mac.

> Using OS X 10.8.4 I can not reproduce this problem. So might be related to
> OS X (which is a very old OS btw).

On my other Mac, which uses 10.8.4, LO 4.1.1.2 rc works just fine.

Maybe the "bug" is in the documentation and system requirements.

http://www.libreoffice.org/download/system-requirements/

Macintosh

The software and hardware prerequisites for installing on a Macintosh computer are as follows:

MacOSX 10.4 (Tiger) or higher;

I was surprised to see Tiger listed.

If it is decided that LO 4.1.x will no longer support 10.5.x and earlier, then the sysreqs should indicate that decision.

If support shall be continued, then I can provide further information, including crash logs.  Here's what I got when I last tried to launch LO 4.1 on Mac 10.5.8:

8/30/13 2:18:34 PM [0x0-0x161c61b].org.libreoffice.script[91479] dyld: unknown required load command 0x80000022 
8/30/13 2:18:34 PM com.apple.launchd[1292] ([0x0-0x161c61b].org.libreoffice.script[91479]) Exited abnormally: Trace/BPT trap
Comment 7 Julien Nabet 2013-09-01 11:59:39 UTC
Steve: do you have a Powerpc or Intel?
Could you copy paste the crash logs in a file and attach it by using this link? https://bugs.freedesktop.org/attachment.cgi?bugid=68771&action=enter
Comment 8 Steve Piercy 2013-09-01 20:59:14 UTC
(In reply to comment #7)
> Steve: do you have a Powerpc or Intel?

  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2.4 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2

> Could you copy paste the crash logs in a file and attach it by using this
> link? https://bugs.freedesktop.org/attachment.cgi?bugid=68771&action=enter

Gladly, if you can tell me where LO dumps its crash log on a Mac.  I didn't find anything obviously LO-ish in the usual spaces that are monitored by Console, except for those two lines I pasted earlier.

--steve
Comment 10 Julien Nabet 2013-09-02 06:03:18 UTC
Here's the Roman's questionnaire too:
"
Here is my complete standard “questionnaire” for such issues:
-------------------------------------------------------------------------------

1) Do you have any accesibility features enabled? Apple’s accessibility
features like “VoiceOver” or “Enable access for assistive devices”, which get
enabled in “System Preferences > Universal Access”, are known to cause many crashes and freezes in LibreOffice. So please try to disable any accesibility features, then check if the problem is still reproducible.

2) Do you have installed any window management/user interface utilities/apps/control panels/extensions for Mac OS X like 
   * AquaSnap                * BetterSnapTool
   * BetterTouchTool         * Breeze
   * Cinch                   * Divvy
   * DoublePane              * Flexiglass
   * HyperDock               * iSnap
   * Moom                    * RightZoom
   * ShiftIt                 * SizeUp
   * SizeWell                * Spectacle
   * Stay                    * TileWindows
   * WindowTidy              * Flavours (from flavours.interacto.net)
... or something similar?

And/or do you use any mouse cursor/pointer utility, i.e. some little application or control panel etc. which animates or replaces etc. the mouse curser/pointer, like
   * LazyMouse?

And/or do you use any special software which could be related to accessibility stuff, e.g. a screen reader, screen magnifier, speech recognition software,
a text-to-speech (dictation) application, or similar?

All these and many similar utilities rely heavily on Mac OS accessibility features and therefore can cause LibreOffice to crash or freeze. So please check if you have installed any utility of this kind and try to disable it
(or to add LibreOffice to the list of excluded applications for the utility,
if there is such a thing).

So please check these possibilities, if any of them helps to make the crash go away, and report the results here.
"
Comment 11 Steve Piercy 2013-09-02 07:59:44 UTC
Created attachment 85045 [details]
LO 4.1.1.2 rc crash log on Mac OS X 10.5.8

Crash log attached, with system config.
Comment 12 Steve Piercy 2013-09-02 08:18:50 UTC
(In reply to comment #10)
> 1) Do you have any accesibility features enabled? Apple’s accessibility
> features like “VoiceOver” or “Enable access for assistive devices”, which get
> enabled in “System Preferences > Universal Access”, are known to cause many
> crashes and freezes in LibreOffice. So please try to disable any
> accesibility features, then check if the problem is still reproducible.

None were enabled, unless "Enable access for assistive devices" counts.

> 2) Do you have installed any window management/user interface
> utilities/apps/control panels/extensions for Mac OS X like 
>    * AquaSnap                * BetterSnapTool
>    * BetterTouchTool         * Breeze
>    * Cinch                   * Divvy
>    * DoublePane              * Flexiglass
>    * HyperDock               * iSnap
>    * Moom                    * RightZoom
>    * ShiftIt                 * SizeUp
>    * SizeWell                * Spectacle
>    * Stay                    * TileWindows
>    * WindowTidy              * Flavours (from flavours.interacto.net)
> ... or something similar?

RightZoom.

> And/or do you use any mouse cursor/pointer utility, i.e. some little
> application or control panel etc. which animates or replaces etc. the mouse
> curser/pointer, like
>    * LazyMouse?

Kensington Mouseworks, but it does not modify the cursor/pointer, only enables features of a track ball mouse.

> And/or do you use any special software which could be related to
> accessibility stuff, e.g. a screen reader, screen magnifier, speech
> recognition software,
> a text-to-speech (dictation) application, or similar?

Nope.

> All these and many similar utilities rely heavily on Mac OS accessibility
> features and therefore can cause LibreOffice to crash or freeze. So please
> check if you have installed any utility of this kind and try to disable it
> (or to add LibreOffice to the list of excluded applications for the utility,
> if there is such a thing).
> 
> So please check these possibilities, if any of them helps to make the crash
> go away, and report the results here.

I disabled "Enable access for assistive devices" in Universal Access and RightZoom.  I could not find an easy way to disable MouseWorks.

I attempted to relaunch.

LO 4.1.1.2 rc still crashes.

--steve
Comment 13 Alex Thurgood 2013-09-02 08:42:38 UTC
Sounds like the deployment target version wasn't set for 10.5 when LO was built, so used libraries that are not available on 10.5.


http://stackoverflow.com/questions/16614636/dyld-unknown-required-load-command-0x80000022-error-with-git-installation


Alex
Comment 14 Alex Thurgood 2013-09-02 08:44:13 UTC
Which machine is responsible for the release build of LO 4.1 that is available from the download page ?

Alex
Comment 15 Alex Thurgood 2013-09-02 08:45:38 UTC
Also note that I think that our baseline SDK has become 10.6, so there may be versions of libraries used which are not compatible with 10.5 ?


Alex
Comment 17 Alex Thurgood 2013-09-02 08:49:29 UTC
Adding Thorsten to CC, as I believe he's the one who manages the OSX release ?

Alex
Comment 18 dan 2013-09-12 08:34:11 UTC
> http://www.libreoffice.org/download/system-requirements/
> Macintosh ...
> MacOSX 10.4 (Tiger) or higher;

OSX Intel - 10.4.11 (Tiger) with LibreOffice-4.1.1

computer:/Applications/LibreOffice.app/Contents/program$ ./soffice 
dyld: unknown required load command 0x80000022
Trace/BPT trap

Works with LibreOffice 4.0.5 - probably time to update the system-requirements documentation (and for me to update my mother's computer :-) )
Comment 19 894y14q 2013-09-12 15:30:41 UTC
Created attachment 85727 [details]
LO 4.1.1 crash log on Mac OS X 10.5.8

I may have the same problem.

I'm running Mac OS X 10.5.8 (Intel). I downloaded and installed LO shortly after its release: "Mac OS X (Intel), version 4.1.1, English (US)". When I started the application, it crashed.

So I downloaded and installed 4.0.5, and had no problem using that.


I now have removed LO from the Applications and have both versions installed on my desktop (renamed to reflect version). I can still use 4.0.5, and 4.1.1 crashes.


Romans questionnaire:
1) Do you have any accesibility features enabled?
No

2) Do you have installed any window management/user interface utilities/apps/control panels/extensions?
No

3) And/or do you use any mouse cursor/pointer utility?
Yes, I have Logitech Control Center to speed up my mouse.


I've attached my crash log, which looks similar to Steve Piercy' crash log and seems to confirm the post from Dan.
Comment 20 894y14q 2013-09-12 15:35:36 UTC
(In reply to comment #19)
> I've attached my crash log, which looks similar to Steve Piercy' crash log
> and seems to confirm the post from Dan.
I meant Alex, not Dan,

http://software.intel.com/en-us/articles/running-an-intel-compiled-binary-on-older-mac-os-x-system-gives-dyld-unknown-required-load
Comment 21 tommy27 2013-09-12 15:39:32 UTC
issue confirmed by another user. set status to NEW.
added regression keyword. added to mab4.1 list.
Comment 22 Michael Meeks 2013-09-12 15:52:44 UTC
Norbert / Christian - who did these builds ? I assume we pulled up our baseline for the toolchain, did we do the same for the OS somehow in error ? cf the very useful Intel link above:

"Root Cause :
Generally, if you are targeting your applicaiton to run on multiple versions of Mac OS X, you should use the 'least common denominator' approach of developing on the older OS version.  This is because newer version may have extended the base OS API but generally newer versions will maintain backwards compatibility."

With apologies - we recently moved to new compile machines in several places with a couple of unpleasant platform side-effects (like this).
Comment 23 Norbert Thiebaud 2013-09-12 16:37:17 UTC
Please refer to the release note:

4.1+ require 10.6 or higher.

4.0+ is the last version that support 10.4/10.5 and PPC
Comment 24 894y14q 2013-09-15 21:48:19 UTC
(In reply to comment #22)
> With apologies - we recently moved to new compile machines in several places
> with a couple of unpleasant platform side-effects (like this).

(In reply to comment #23)
> Please refer to the release note:
> 
> 4.1+ require 10.6 or higher.
> 
> 4.0+ is the last version that support 10.4/10.5 and PPC

Just so I understand, because the new compile machine is incompatible with the old compile machine (and said resolution is apparently not an option), the 'fix' will be updating the system requirements page?

Personally, I find the Status 'resolved'/'not-a-bug' a bit strange. IMHO when 'Joe Regular'-user launches an application and it crashes it's a bug.
Other applications no longer supporting 10.5 redirect me to an older release still supporting 10.5. Even when manually overriding the download to a newer version, the OS prevents me from launching it. I don't know how that works though.

I'm a bit disappointed in the chosen path.
Comment 25 Norbert Thiebaud 2013-09-15 22:02:15 UTC
It is not about machine...
The machine that do the 4.1 release is the same that do the 4.0 release...

It is a question fo SDK support and requirement...
Requiring 10.4/10.5, which are not supported by Apple, is a pain and is blocking development.
We decided that 4.0 will be the last version that we support, that support 10.4/10.5... and for 4.1+ we bump the SDK requirement to 10.6.

So no, this is not a hardware consideration (although it would become one rapidly, since finding Mac that can do 10.4 build is getting quite problematic... The release box is 5 years old already.. and will die someday)

But a practical design choice... We dropped support for Windows 2000, Win95 and OS/2 too mind you... we just can't afford to support platform for-ever...

Some volunteer recently worked on back-porting 4.1 to 10.5 PPC... that is most welcome, and patch in that direction will be regarded favorably... if there is a community that want to take on the burden, more power to it... We just will not continue to provide binary for it as part of our normal release, nor continue to impose restriction on our devs wrt to compatibility with 10.4/10.5
iow if someone were to pick up the challenge, that someone would need to expect breakage, as master will not try to use API that are backward compat up to 10.4 anymore....
Comment 26 Michael Meeks 2013-09-16 08:09:40 UTC
The outcome of crashing is a bit unexpected :-) is there any flag we can set in some Mac app description that gives a minimum OS version - to get a friendly OS provided error ? and/or could we have a shell-script in our wrapper (if we have one on Mac) that checks the OS version & warns in a friendly way for older OS/X ?

Surely other people have this problem; a quick google showed:

https://developer.apple.com/library/ios/documentation/general/Reference/InfoPlistKeyReference/Articles/LaunchServicesKeys.html

and: LSMinimumSystemVersion

but perhaps we have to be running to set that ?
Comment 27 Michael Meeks 2013-09-16 08:12:50 UTC
re-opening with a new title. I'm no OS/X expert but would something like this help (sadly I've no way of testing it):

diff --git a/sysui/desktop/macosx/Info.plist b/sysui/desktop/macosx/Info.plist
index 5a682dc..13500d7 100755
--- a/sysui/desktop/macosx/Info.plist
+++ b/sysui/desktop/macosx/Info.plist
@@ -1422,6 +1422,8 @@
        <string>VCL_NSApplication</string>
     <key>LSApplicationCategoryType</key>
     <string>public.app-category.productivity</string>
-</dict>
+    <key>LSMinimumSystemVersion</key>
+    <string>10.6.0</string>
+</dict2>
 </plist>
Comment 28 894y14q 2013-09-16 21:03:11 UTC
(In reply to comment #27)
> +    <key>LSMinimumSystemVersion</key>
> +    <string>10.6.0</string>
> +</dict2>
>  </plist>

It just so happens, I have a Mac 10.5.8.

(the short answer is: yes, that works).


Anywhow, I manually added LSMinimumSystemVersion and LSMinimumSystemVersionByArchitecture to the Info.plist and started LO.
Setting it to version 10.4.0 or 10.5.0, LO still seems to work. Meaning it doesn't crash, it allows me to create a text document etc.
So I changed it to 10.6.0 and launched LO... It crashes. This time the crash report really rocks with a whole bunch of complicated strings and numbers all over the place. None seems to indicate a version conflict. But, read on.

The alternatives:
- I found Adium (www.adium.im) has a good way detecting the OS version (I'll add a screenshot). The plist.info is a binary version of the xml (using plist you can switch between xml and binary). But I didn't know that at first. So I checked their IRC channel where "xnyphs" revealed this mystery and confirmed the usage of <LSMinimumSystemVersion>. (s)he also indicated I may have run into a cashing issue in finder, clarifying the rocky crash.
So I copied the LO application (MinimumSystemVersion set to 10.6.0) to my desktop, and lo and behold.

- A whole different way is how a Java update (JavaForMacOSX10.6.Update16) does it. It is a installation package that detects the OS version conflict and prevents the user from installing. I don't have a pkg editor so I can't check how that works.
Comment 29 894y14q 2013-09-16 21:03:48 UTC
Created attachment 85937 [details]
Adium shows incompatible version before installing
Comment 30 894y14q 2013-09-16 21:05:16 UTC
Created attachment 85938 [details]
lo and behold: LO shows incompatible version
Comment 31 Stephan Hradek 2013-10-27 14:16:15 UTC
I just downloaded 4.1.x as it's said to be compatible to 10.5.8 but it crashes for me too

Process:         soffice [3284]
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:      org.libreoffice.script
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [220]

Interval Since Last Report:          386037 sec
Crashes Since Last Report:           7
Per-App Interval Since Last Report:  0 sec
Per-App Crashes Since Last Report:   1

Date/Time:       2013-10-27 14:35:55.577 +0100
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  6AE5E93E-9A13-4CFD-B406-C14BA7AF3C7D

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  unknown required load command 0x80000022

If it's not compatible, why do you not state on the Requirments page? If it's just a compiler flag, why don't you set it? It's a bit annoying, having to download several versions to find a compatible one :(
Comment 32 Michael Meeks 2013-10-28 19:56:24 UTC
Stephan - which requirements page did you read before downloading ?
I guess we could do something clever in the browser / download page too ... ;-) [ ever more download-page feature requests for Cloph ].
Comment 33 Norbert Thiebaud 2014-01-19 06:10:25 UTC
4.1 has never supported 10.5
This was announced in December 2012.
Now 4.2 has added plist info to detect attempt to run with an unsupported version