Bug Hunting Session
Bug 68893 - VIEWING: EPS embedded images not shown
Summary: VIEWING: EPS embedded images not shown
Status: RESOLVED DUPLICATE of bug 47458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-09-03 16:02 UTC by Gilles Gravier
Modified: 2013-09-06 11:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File with problem described above. (23.40 KB, application/vnd.oasis.opendocument.text)
2013-09-03 16:02 UTC, Gilles Gravier
Details
Screenshot Ubuntu 12.04 LTS 32 bits LO 3.5.7.2 (335.28 KB, image/png)
2013-09-06 05:25 UTC, Gilles Gravier
Details
Screenshot Ubuntu 12.04 LTS 32 bits LO 4.1.1.2 (316.72 KB, image/png)
2013-09-06 05:26 UTC, Gilles Gravier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gilles Gravier 2013-09-03 16:02:31 UTC
Created attachment 85122 [details]
File with problem described above.

Hi!

The attached file includes EPS images embedded.

If I open it with LibreOffice 3.5.7 on Ubuntu 12.04, it displays fine. And works fine (exporting to PDF works, for example).

If I open it with LibreOffice 4.1.1 on Ubuntu 13.04 or Windows 7, I get an error and the image is replaced by a placeholder with some technical information displayed.

This is a serious regression.

Can you look into it?

Thanks,
Gilles.
Operating System: All
Version: 4.1.1.2 rc
Last worked in: 3.5 all versions
Comment 1 tommy27 2013-09-05 23:17:00 UTC
I tested with 3.4.6, 3.5.7 and 4.1.1 under Win7 64bit and the document look the same... however I see no image but placeholders with "creator:cairo 1.12.2 blah blah blah" in each version... so I suppose that in Windows the bug affects each version.

please post a screenshot of what you see in 3.5.7 and what you see in 4.1.1 under Linux.

P.S. edited summary notes to a better description
Comment 2 Gilles Gravier 2013-09-06 05:25:57 UTC
Created attachment 85303 [details]
Screenshot Ubuntu 12.04 LTS 32 bits LO 3.5.7.2

Ubuntu 12.04 LTS 32 bits with all latest patches... and original LibreOffice 3.5.7.2 that came with it.

Document opens fine.
Comment 3 Gilles Gravier 2013-09-06 05:26:58 UTC
Created attachment 85304 [details]
Screenshot Ubuntu 12.04 LTS 32 bits LO 4.1.1.2

Same file after updating LibreOffice through ppa:libreoffice/ppa  to 4.1.1.2

Problem appears
Comment 4 tommy27 2013-09-06 06:09:49 UTC
one more question: do you reproduce the bug just with those EPS (the one with your company logo) or with any other EPS?
Comment 5 Gilles Gravier 2013-09-06 06:31:25 UTC
Hi,

I've added 2 screenshots. And just to make things very easy, here are steps to reproduce the behavior.

1) Install latest version of VirtualBox on your machine.
2) Create a VM with Ubuntu 12.04 LTS 32 bits
3) Update all patches on this VM
4) Download and open the original submitted file (modèle lettre_v7.odt) (so, with LibreOffice 3.5.7.2)
5) See that it works fine
6) Add the LO PPO : sudo add-apt-repository ppa:libreoffice/ppa
7) Update again to install latest LP : sudo apt-get update && sudo apt-get dist-upgrade
8) Open the same original submitted file (modèle lettre_v7.odt) (so, with LibreOffice 4.1.1.2)
9) See that it doesn't display correctly

The 2 screenshots were obtained that way.
Comment 6 Gilles Gravier 2013-09-06 07:00:02 UTC
Note that I've only experienced it with this document... but... only because I haven't had another similar document to test with.

Nevertheless, I have seen other people mentionning documents with embedded EPS files not working properly, so I suspect this is not a one shot issue...

As I said in my previous comment, just install VBox on your Win7x64 machine, and install Ubuntu 12.04 LTS (32 bit, but it also behaves the same on a 64 bit Ubuntu 12.04 LTS). Open the doc in the original LO 3.5.7.2, update LO to 4.1.1.2 through the ppa:libreoffice/ppa. Open the document again in LO 4.1.1.2 and notice the difference...

Gilles.
Comment 7 ign_christian 2013-09-06 08:05:14 UTC
Hello Gilles, I can also confirm that file looks ok with LO 3.6.7.2 (Ubuntu 12.04 32bit). Same as your screenshot with 3.5.7.2

As far as I remember, I ever saw this behavior reported previously (with EPS image) in other bugs with LO 4.x. Perhaps you could do a favor searching that :) 

I think we should set to NEW since tommy27 confirmed with 4.1
Comment 8 Gilles Gravier 2013-09-06 08:28:28 UTC
Hi!

Maybe this is similar to this bug : https://bugs.freedesktop.org/show_bug.cgi?id=47458

Gilles
Comment 9 tommy27 2013-09-06 11:12:58 UTC
yes. this is a DUP of Bug 47458

the interesting thing is that 3.6.x works in Linux while is broken in Windows.

*** This bug has been marked as a duplicate of bug 47458 ***