Bug 68923 - EDITING: Difficult to select text frame whith a master page
Summary: EDITING: Difficult to select text frame whith a master page
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, bisected, regression
: 77539 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-04 09:33 UTC by Laurent BP
Modified: 2015-12-17 07:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2013-09-04 09:33:47 UTC
Problem description: 

Steps to reproduce:
1. Create a new presentation
2. Select a master page (for instance AbstractRed) or in View > Master > Slide Master create a rectangle which cover all the slide and send it in the background (right click > Arrange > Send to back)
3. Enter text in a frame (Subtitle or Title)
4. Click on frame to select the text frame (if you want to change size for instance)

Current behavior:
Text frame is not selected, nothing is selected

Expected behavior:
Text frame should be selected

There is no problem if no master page is selected. There is no problem if a background is defined through Format > Page > Background

Workarounds:
- long click on text frame keeps it selected
- hit ESC key
- Ctrl+click or Alt+click

Confirmed on Win 7 with LibO 4.0.4.2, LibO 4.1.1.2 and LibO 4.2.0.0.alpha0+
Build ID: 4a8f7ddc290d1ea3131de6611b6833b77ac7ab1f

NOT reproduced with LibO 4.0.5.2

              
Operating System: Windows 7
Version: 4.1.0.4 release
Comment 1 Laurent BP 2013-09-04 09:40:31 UTC
Oups, please correct version number in comment#1
LibO 4.0.4.2 => LibO 4.1.0.4 reproduce the bug.
Comment 2 Pierre C 2013-09-04 12:05:15 UTC
Confirm under Seven 64 bit

One other problem that seems to be liked to that one.

1 create new presentation with no background
2 Add a text and a picture
3 click into the text
4 click in the picture to select it -> the picture is selected
5 add a background with mater pages
6 click into the text
7 click in the picture -> you can't select the picture

it works fine with LibO 4.0.5
Comment 3 Jean-Baptiste Faure 2013-09-05 20:26:05 UTC
Reproducible on Ubuntu 13.04 with LO 4.1.3.0+
workaround: maj+click works too.

Best regards. JBF
Comment 4 Pierre C 2013-10-03 07:33:34 UTC
Still works fine with Libo 4.0.6.1 but still bugged with 4.1.2.3. very Annoying bug
Comment 5 Pierre C 2013-10-03 08:08:13 UTC
But difficulty to select an image when cursor is on a text frame is now present in 4.0.6.1 (comment 2)

so it seems that there are two different bugs
Comment 6 Jean-Baptiste Faure 2013-10-06 13:04:01 UTC
Set platform to ALL due to comment #3
Comment 7 Pierre C 2014-04-16 19:44:55 UTC
*** Bug 77539 has been marked as a duplicate of this bug. ***
Comment 8 Pierre C 2014-04-16 19:45:30 UTC
Still present in 4.2.3 ; and master branch
Comment 9 Matthew Francis 2014-12-06 07:04:38 UTC
Results from bibisect-43all:

There is a large range between
source-hash-5da10275a7475efdbfd9de14ea58cf8f4c6c1582
and
source-hash-bd7b2c7befbd10bebaba3a9b6ea491969ac1dcb0
in which selecting a master page in Impress causes a crash. Using the second reproduction technique of manually drawing a rectangle on the master page gave the following:


a7e54955e9f49e8b59dfd8c4533785a680b1796c is the first bad commit
commit a7e54955e9f49e8b59dfd8c4533785a680b1796c
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Oct 16 11:07:50 2013 +0000

    source-hash-5da10275a7475efdbfd9de14ea58cf8f4c6c1582
    
    commit 5da10275a7475efdbfd9de14ea58cf8f4c6c1582
    Author:     Stephan Bergmann <sbergman@redhat.com>
    AuthorDate: Fri Mar 1 17:09:45 2013 +0100
    Commit:     Stephan Bergmann <sbergman@redhat.com>
    CommitDate: Fri Mar 1 17:18:29 2013 +0100
    
        Related rhbz#915743: Abort UCB call from SvtMatchContext_Impl::Stop
    
        ...as otherwise the SvtMatchContext_Impl thread can continue to run for
        arbitrarily long, and the other thread calling Stop() and join() will block.
    
        However, especially the WebDAV UCP does not properly support aborting commands,
        see 260afe56fd6b2f34de8290f3cdb7d1df5b88f8a8 " neon commands cannot be aborted",
        so this is not yet enough to actually fix rhbz#915743 "thread deadlock/slow
        join in insert->hyperlink in impress."
    
        Change-Id: I0da899f824763e1b3d19bb5b38d906feb690b623


# bad: [c2069a369d738078124812312d51f21ea1ce2421] source-hash-f160e4935c474a5293b3d3c11b3d538efb4767a0
# good: [cf86b7f14a98d2d81a5cd93507acb35ff6775d8b] source-hash-85c6244b85b29c1d2bb9d89b62e9512dd65378b5
git bisect start 'last41onmaster' 'last35onmaster'
# good: [cd18cb7f47f7e956c6d19bd0f31a6e30d1173b29] source-hash-558476135865d9ae7b8801a82c177fd1098386ff
git bisect good cd18cb7f47f7e956c6d19bd0f31a6e30d1173b29
# bad: [a7e54955e9f49e8b59dfd8c4533785a680b1796c] source-hash-5da10275a7475efdbfd9de14ea58cf8f4c6c1582
git bisect bad a7e54955e9f49e8b59dfd8c4533785a680b1796c
# good: [1f14665c5624bc7a502738aa8f4f2bd70a211e72] source-hash-d85fd8a85501547d5bb87822d2589a07aed7f2d6
git bisect good 1f14665c5624bc7a502738aa8f4f2bd70a211e72
# good: [65831911b71b1982c9c2c759fd80b8e9404e9641] source-hash-3a9e1e71d9a28b2c6bc96757e629b231d2276d9d
git bisect good 65831911b71b1982c9c2c759fd80b8e9404e9641
# good: [b9da5d7ef8baf81aa867fc44cb6d8ebb6036201b] source-hash-ec376c2934e77fd1b56da892cfe2c1393f4c8156
git bisect good b9da5d7ef8baf81aa867fc44cb6d8ebb6036201b
# good: [31bac4fcc40da1e460b132be36dfa002e52919d0] source-hash-d55155cad0926f61b5745260196b93e95471d06a
git bisect good 31bac4fcc40da1e460b132be36dfa002e52919d0
# good: [85835eaea0e00bbe3138486781a507e436bc9263] source-hash-6978ddbf4738b4c53b9d2edbe6d5ad6a061d0d0f
git bisect good 85835eaea0e00bbe3138486781a507e436bc9263
# good: [5e90d936616ff95724eaa3e3a0a7c7a9747e9b44] source-hash-ba446dd58a4ad324d242afcd5b28d3b4dff5a881
git bisect good 5e90d936616ff95724eaa3e3a0a7c7a9747e9b44
# first bad commit: [a7e54955e9f49e8b59dfd8c4533785a680b1796c] source-hash-5da10275a7475efdbfd9de14ea58cf8f4c6c1582
Comment 10 Matthew Francis 2015-01-15 05:37:57 UTC
The behaviour seems to have changed as of the below commit.

Adding Cc: to Wasserthal@nefkom.net; Could you possibly take a look at this? Thanks


commit e80a8b6f14fac6bb6cc7ea55b118f95472d5b654
Author: Lennard Wasserthal <Wasserthal@nefkom.net>
Date:   Sat Feb 9 14:31:21 2013 +0100

    fdo#55430 switches off text mode when clicking an other object.
    
    This patch complements 85ea03ae536831649b104694d08dced4d4c8663f (and
    6fbba11da54b52554941f00b07e42cc5d7a1643c, which didn't work correctly before)
    This also fixes issues when clicking on another object to stop text editing.
    Switches off text mode, and instantaneously selects the other object.
    (Rotation doesn't belong into the ./sd/ text routine AT ALL, which also caused bug 37482,
    which is resolved differently from now on)
    (Creating text fields doesn't belong into the ./sc/ shape text routine either, and if this executed, it causes funny glitches)
    Known issues: text mode stays on when you use drag'n drop (the one WITH waiting, to move to other applications etc).
    
    Change-Id: I3c8cdedbfae58165ebeda5887c1b6573832eb495
    Signed-off-by: Lennard Wasserthal <Wasserthal@nefkom.net>
    Reviewed-on: https://gerrit.libreoffice.org/1344
    Reviewed-by: Tor Lillqvist <tml@iki.fi>
    Tested-by: Tor Lillqvist <tml@iki.fi>
Comment 11 Pierre C 2015-07-11 09:19:11 UTC
AFAICS theses bugs seems to be solved in LO 5.0.0.3 x64
Comment 12 Buovjaga 2015-07-11 09:32:42 UTC
Thanks for testing. Let's set to WFM, then. Set back to NEW, if you still bump into them.
Comment 13 Laurent BP 2015-07-29 20:30:57 UTC
This was fixed between 4.4.4.2 and 4.4.5.1
Good job :)
Comment 14 Robinson Tryon (qubit) 2015-12-17 07:30:07 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]