Bug 68959 - FORMATING Tabulation fill character not visible if small capitals font effect is turned on
Summary: FORMATING Tabulation fill character not visible if small capitals font effect...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Michael Stahl
QA Contact:
URL:
Whiteboard: target:4.3.0 target:4.1.5 target:4.2.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-09-04 22:37 UTC by alexo
Modified: 2014-01-30 15:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ODT/PDF/PNG illustrating tab leaders not being displayed for small caps under v4132. (291.20 KB, application/zip)
2013-11-23 02:50 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alexo 2013-09-04 22:37:27 UTC
Tabulation fill character characters disapear when font effect is set to "smal capitals".

Steps to reproduce the bug:
1) write some text and set an arbitrary trabulation using any fill characters.
2) set font effect to small capitals

I also can confirm this bug is not present in LibreOffice 4.0.5 x86_64 (Arch Linux)
Comment 1 Owen Genat (retired) 2013-11-23 02:50:51 UTC
Created attachment 89670 [details]
ODT/PDF/PNG illustrating tab leaders not being displayed for small caps under v4132.

Tested under Ubuntu 10.04 x86_64 running:

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

As the screenshots indicate all but the most recent version displays the character used in the tab when Format > Character... > Font Effects tab > Effects of "Small capitals" is applied.
Comment 2 Owen Genat (retired) 2013-11-23 02:52:08 UTC
Confirmed in comment #1. Status set to NEW. Keyword "regression" added.
Comment 3 Michael Stahl 2014-01-21 10:27:00 UTC
regression from:

commit f22006dc6ac34a35a060e15466cf6b2d2058617d
Author:     Luboš Luňák <l.lunak@suse.cz>
AuthorDate: Wed Apr 17 18:52:28 2013 +0200

    fix stupid over-optimization
    
    There's so little to be gained by storing pointers to simple
    or refcounted types instead of using an instance. At least
    SwTxtNode::GetMinMaxSize() and SwTxtNode::GetScalingOfSelectedText()
    pass string temporaries to SwDrawTextInfo, so keeping a pointer
    is clearly broken, and MSVC manages to optimize the code enough
    to crash because of this. As all the pointers point to const references
    and are accesses using const references as well, there shouldn't
    be any harm in making a copy.
    This fixes smoketest crash on Windows.


... specifically the change to convert "pPos" from Point const* to Point
means that SwDrawTextInfo::Shift() and  SwDoDrawStretchCapital::Do()
(which used to modify the "const Point", eek!) now have a permanent effect
apparently because their changes are not reverted.

fixed on master
Comment 4 Commit Notification 2014-01-21 10:28:10 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c445d40da8daa2f6ec0ae9930a06f50ab80cc85d

fdo#68959: sw: fix painting of tab fill characters in small caps text



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-01-21 10:51:09 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7cdf5a6995a017e295e9b1099abc6dcb1987ae9e&h=libreoffice-4-1

fdo#68959: sw: fix painting of tab fill characters in small caps text


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-01-21 10:51:24 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b038679c550d2a0178c1beca368a86598dd0c80b&h=libreoffice-4-2

fdo#68959: sw: fix painting of tab fill characters in small caps text


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-01-21 15:54:03 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98176bc2078d4ce18d4eb41b54b4ad1c72a2774d&h=libreoffice-4-2-0

fdo#68959: sw: fix painting of tab fill characters in small caps text


It will be available already in LibreOffice 4.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-01-30 15:08:13 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28c613edb7bde90c49c61c56c9bb32fb312070e9&h=libreoffice-4-1-5

fdo#68959: sw: fix painting of tab fill characters in small caps text


It will be available already in LibreOffice 4.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.