Bug Hunting Session
Bug 68972 - UI: Feature request: add personal equations in the "Examples" section of the Math Elements doking window
Summary: UI: Feature request: add personal equations in the "Examples" section of the ...
Status: RESOLVED DUPLICATE of bug 68507
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-05 09:51 UTC by marco_pace
Modified: 2013-09-08 12:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing current list (5) of Examples. (52.05 KB, image/png)
2013-09-06 01:35 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marco_pace 2013-09-05 09:51:28 UTC
Problem description:

Hi there,
I think would be great to have the possibility to add the most frequently used formulas in the “Examples” section (or even better, in a new section, e.g.: “Personal Formulas”) in the new Elements Docking window introduced in LO 4.1, so to have the possibility to re-enter them with just a click.
Thanks a lot, and keep up the good work!
Mark.

Current behavior:
Formulas in the "Examples" sections cannot be edited

Expected behavior:
One should be able to add and/or edit formulas in a personal section of the Elements docking windows, so to be able to re-enter them with just one click
Operating System: All
Version: 4.1.0.4 release
Comment 1 Owen Genat (retired) 2013-09-06 01:35:10 UTC
Created attachment 85298 [details]
Screenshot showing current list (5) of Examples.

Screenshot shows TDF/LO Math v4.1.0.4 running under Crunchbang 11.
Comment 2 Owen Genat (retired) 2013-09-06 02:02:55 UTC
I am confirming this report. Setting severity to Enhancement and Status to NEW. The screenshot in comment #1 shows the current list of five examples. If I understand the request correctly, the suggestion is that some sort of facility be included that remembers / saves recently included or preferred equations and populates a list of them for easier access. 

Whether this is done via the existing "Examples" section of the Elements panel or a new section (e.g., "Recent" or "Personal") is open to opinion. I agree with the original reporter that a separate section is better, as the examples are not really a list of preferred / personal / favourite / recent equations.

How equations are included on this new list also needs to be considered. Until this is resolved the status may need to be set to NEEDINFO rather than NEW. The feature could be entirely automatic (as with the Recent Files list), although this is more a list of recently edited equations and IMO less in keeping with what the reporter is suggesting. Alternatively it could be an optionally populated list, especially if the list is to be more "personal" (i.e., favourites) rather than "recent". In this case some sort of check-box or similar option would be required to allow selective inclusion.
Comment 3 marco_pace 2013-09-06 08:49:56 UTC
A "simple" (!) drag and drop function would also be great to add formulas to the "Personal" section
Comment 4 Thomas Arnhold 2013-09-08 12:52:49 UTC

*** This bug has been marked as a duplicate of bug 67862 ***
Comment 5 Thomas Arnhold 2013-09-08 12:55:50 UTC
Sorry wrong bug number, this was it fdo#68507

*** This bug has been marked as a duplicate of bug 68507 ***