Download it now!
Bug 68981 - dataloss: "thisComponent.store" corrupts the macro library password
Summary: dataloss: "thisComponent.store" corrupts the macro library password
Status: RESOLVED DUPLICATE of bug 68983
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: Other All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-09-05 13:07 UTC by pierre-yves samyn
Modified: 2015-12-18 09:52 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
LibraryPassword.ods (after step 5) (9.46 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-09-05 13:07 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2013-09-05 13:07:10 UTC
Created attachment 85252 [details]
LibraryPassword.ods (after step 5)

Hello

When a document (calc/writer...) contains a macro in a library protected by password and runs "thisComponent.store" instruction, the password no longer allows to open the library.

Steps to Reproduce:

Open the attached LibraryPassword.ods spreadsheet and continue to step 6, or follow steps 1-5 below and continue.

1. File> New> Spreadsheet
2. Tools> Macros> Organize> LibO Basic, click Organizer, tab Libraries, location:Untitled 1, click New, name Library1, Ok
3. Click Password: foo (confirm), Ok
4. Click Edit: in Module1 of Library1, create the following macro:

sub Main
thisComponent.store
End Sub

5. Save the document normally (without using the macro Main) and close it.
6. Reopen the document
7. Tools> Macros> Run macro> LibraryPassword.ods> Library> Module1> Main.
8. Tools> Macros> Organize> LibO Basic> LibraryPassword.ods> Library
Type the password (foo).

Expected result: password verified and ability to edit
Actual result: error message "Incorrect Password", access denied

Remarks:
- Reproduced (fr-users) with Windows XP & 4.1.0.4
- Does not occur with OpenOffice
- By cons, once the password corrupted with LibreOffice, it is also rejected with OpenOffice
- Does not seem to occur with 3.x releases
- Bug vicious, macros always work and you can not see that the library cannot be edited
- Thousands of lines of code currently inaccessible, besides the bug fix, a recovery process corrupted documents would be welcome

Best regards
Pierre-Yves
Comment 1 pierre-yves samyn 2013-09-05 13:38:40 UTC
May be related to bug 68983
Comment 2 Jean-Baptiste Faure 2013-09-05 19:55:30 UTC
Added the keyword dataloss in the summary.
Comment 3 Björn Michaelsen 2014-01-17 09:51:45 UTC
(This is an automated message.)

Setting priority to highest as this is a 4.1 MAB. This is part of an effort to make the importance of MAB reflected in priority too.
Comment 4 tommy27 2014-05-08 12:19:14 UTC
please retest against newly released LibO 4.2.4.2
if issue is still there please move it to the mab4.2 list
Comment 5 pierre-yves samyn 2014-05-08 13:06:37 UTC
Hello

(In reply to comment #4)
> please retest against newly released LibO 4.2.4.2
> if issue is still there please move it to the mab4.2 list

Still occurs in Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

move to mab4.2
Comment 6 Lionel Elie Mamane 2014-05-31 03:12:53 UTC
Cannot reproduce on master

commit 82e1456e9ae19cd536c11b2bdda7a79909269c15
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Fri May 30 05:15:01 2014 +0200

    remove fsanitize=address from libgetuid.so makefile
    
    Change-Id: I3d292638b76ed09d84df36d096f70c9496a23fdf


which, in particular, has the fix for bug 68983. This bugs also "smells" like a DUP of bug 68983, so marking as such. Please reopen if you can reproduce with any version where bug 68983 is fixed:

 - 4.2.5.1 (RC1): https://www.libreoffice.org/download/libreoffice-fresh/?version=4.2.5
 - any nightly (4.2, 4.3 or master) build after 26 May: http://dev-builds.libreoffice.org/daily/

*** This bug has been marked as a duplicate of bug 68983 ***
Comment 7 Robinson Tryon (qubit) 2015-12-18 09:52:59 UTC
Migrating Whiteboard tags to Keywords: (dataloss)
[NinjaEdit]