Bug Hunting Session
Bug 68985 - Program halt: Formatted text [RTF] copying of columns from Calc to Writer
Summary: Program halt: Formatted text [RTF] copying of columns from Calc to Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTF RTF-Paste
  Show dependency treegraph
 
Reported: 2013-09-05 14:19 UTC by László Németh
Modified: 2018-07-10 19:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description László Németh 2013-09-05 14:19:13 UTC
Steps to reproduce:

1. Select and copy a column in Calc
2. Paste special as Formatted text [RTF] in Writer

Normal paste has got a problem, too, but only a usability one, the inserted OLE object will have zero width, but Paste special/HTML and DDE-link are usable. But halting with Formatted text [RTF] is not acceptable.

WORKAROUND: copy columns into a new sheet in Calc, and select all sheet (Ctrl-A, Ctrl-C) and paste as Formatted text [RTF] in Writer.
Comment 1 Cor Nouws 2013-09-05 15:28:39 UTC
Hi László
Juist out of curiousity: why should one want to paste 1048576 cells from Calc to Writer :)
Comment 2 László Németh 2013-09-05 15:37:34 UTC
Cor: :) Only the users want to insert their non-empty cells, as in MS Office or as with full sheets in LibreOffice (try it with a full selection, it will work).
Comment 3 QA Administrators 2015-04-01 14:40:11 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-04-20 15:43:50 UTC
Program doesn't halt anymore, but it only pastes one cell.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI
Comment 5 QA Administrators 2016-09-20 09:32:11 UTC Comment hidden (obsolete)
Comment 6 Telesto 2017-05-10 16:32:57 UTC
Still the same as in comment 4
Version: 5.4.0.0.alpha1+
Build ID: 9d320ec4d818f86e58a15fd46248026502b1cc94
CPU threads: 4; OS: Windows 6.2; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-09_01:27:12
Locale: en-US (nl_NL); Calc: single
Comment 7 Timur 2018-07-10 18:20:00 UTC
I may not understand this bug but looks like WFM.
Halt from 3.3 is no more. RTF paste works for non-empty cells. 
If I'm wrong, please explain exactly what's the bug here.
Comment 8 Buovjaga 2018-07-10 19:10:55 UTC
Hmm, yes it may be that my comment 4 was a brainfart and I tested with an empty column. It works fine and logically.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: c290f692dd28094d41dff686f3faa1c4e14b556e
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on July 10th 2018