Bug 68988 - FILEOPEN DOC Bullet size is smaller than it should be
Summary: FILEOPEN DOC Bullet size is smaller than it should be
Status: RESOLVED DUPLICATE of bug 85964
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, filter:doc, regression
Depends on:
Blocks: DOC-Bullet-Number-Lists
  Show dependency treegraph
 
Reported: 2013-09-05 16:27 UTC by Michael Kůr
Modified: 2019-09-10 09:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
I want this. (42.13 KB, image/png)
2013-09-05 16:27 UTC, Michael Kůr
Details
Libre office doing this (40.13 KB, image/png)
2013-09-05 16:29 UTC, Michael Kůr
Details
The text document (430.00 KB, application/msword)
2013-09-05 16:30 UTC, Michael Kůr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Kůr 2013-09-05 16:27:24 UTC
Created attachment 85270 [details]
I want this.

Libre Office changing bullets stile, so that is only small dots (changes will effect after reload file). And at the numbering the LO will set italic style to numbering.

Steps to reproduce:
1) Create some bullets and numberings
2) Save as doc file
3) Reload
Comment 1 Michael Kůr 2013-09-05 16:29:23 UTC
Created attachment 85271 [details]
Libre office doing this
Comment 2 Michael Kůr 2013-09-05 16:30:25 UTC
Created attachment 85272 [details]
The text document
Comment 3 Thomas van der Meulen 2013-09-10 14:20:51 UTC
It looks like the bullets are smale wenn I open the .cgi file so not a file saving but but a opening bug.

Version: 4.1.2.1
Build ID: bf15ac65c2167fb1ef3daf3710609d4a4c369a9
on Mac osx 10.8.4. 

Thank you for reporthing this bug.
Comment 4 Michael Kůr 2014-09-17 08:11:14 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2015-10-14 19:57:15 UTC Comment hidden (obsolete)
Comment 6 Michael Kůr 2015-10-15 13:48:31 UTC
Nothing changed the bug bahavior is same as in first post.
Vesion: LibreOffice 5.0.
OS: Windows 10
Comment 7 QA Administrators 2016-11-08 11:19:59 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2017-10-03 14:41:55 UTC
Still reproducible in

Version: 6.0.0.0.alpha0+
Build ID: 34e8fd7e99489e9f50a512b07c6f3923b358b4d3
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 9 Buovjaga 2018-06-30 16:23:31 UTC
Bibisected with 43all on Linux and range is https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=34847f1cf7538c333e9b8700eb4012ae358644a6...d4779887636fa9ab5b477f3436bcd3728a3e30ba

This looks suspicious: https://cgit.freedesktop.org/libreoffice/core/commit/?id=1c22545edf9085b9f2656ca92781158b6b123db3
Fix issue #i119405: Numbering text style changed after importing the *.doc

No point in adding anyone to CC.
Comment 10 QA Administrators 2019-07-01 02:46:33 UTC Comment hidden (obsolete)
Comment 11 Timur 2019-09-10 09:38:51 UTC
Bug not clear. Title says "FILEOPEN" and steps say "Save as doc" which contradicts. 
Also DOC attachment 85272 [details] not clear where created, MSO or LO, which is very important. Although fileopen issue still exist, if document is LO modified, which I believe, than it's not relevant. 
I guess this is the same issue as Bug 85964 that I reproduced in LO 6.4+. For LO created document, there's a problem with bullets. 
If MSO created document with bullets, LO opens and saves fine.
I'll mark this one duplicate. 
If someone has an explanation what is different, feel free to make it clear, write steps to reporduce and set again to New.

*** This bug has been marked as a duplicate of bug 85964 ***