Bug 68993 - FORMATTING: Improperly formatted text when importing Microsoft PowerPoint smartArt
Summary: FORMATTING: Improperly formatted text when importing Microsoft PowerPoint sma...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: OOXML-SmartArt
  Show dependency treegraph
 
Reported: 2013-09-05 18:28 UTC by mrblankface20002
Modified: 2018-04-20 10:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
This is what you see when you import a 2013 PowerPoint with smart art. In the original, the letters are not broken between lines (45.33 KB, image/png)
2013-09-05 18:28 UTC, mrblankface20002
Details
This is what the original powerpoint looks like (46.65 KB, image/png)
2013-09-05 18:29 UTC, mrblankface20002
Details
powerpoint with smartart used in the images (51.06 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-09-06 18:53 UTC, mrblankface20002
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mrblankface20002 2013-09-05 18:28:25 UTC
Created attachment 85274 [details]
This is what you see when you import a 2013 PowerPoint with smart art. In the original, the letters are not broken between lines

Problem description: 

When you import a Powerpoint made in  Microsoft Word 2007 with smartArt, the smartArt doesn't show up.

When you import a PowerPoint made in Microsoft Word 2013 with smartArt, the text formatting on the smartArt doesn't look correct. See attached pictures

Steps to reproduce:
1. In PowerPoint 2013, create a powerpoint with smartArt. Type some words

2. Import this presentation into Libreoffice Impress

3. See how the formatting is messed up

Current behavior:

Text formatting is broken.

Expected behavior:

Text formatting appears the same
Operating System: Windows 7
Version: 4.1.0.4 release
Comment 1 mrblankface20002 2013-09-05 18:29:34 UTC
Created attachment 85275 [details]
This is what the original powerpoint looks like
Comment 2 mrblankface20002 2013-09-06 18:53:03 UTC
Created attachment 85366 [details]
powerpoint with smartart used in the images
Comment 3 Thomas van der Meulen 2013-09-29 07:30:35 UTC
Thank you for your bug report,
I can reproduce this bug running LibreOffice: 
Version: 4.2.0.0.alpha0+
Build ID: 164b6ce7b27c0a9ec19019e7b078b9f8f382007d
TinderBox: Win-x86@39, Branch:master, Time: 2013-09-28_16:39:4
And Mircosoft Powerpoint 2007
Comment 4 QA Administrators 2015-04-01 14:40:28 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-04-22 11:11:48 UTC
Words not broken anymore, but positioning still doesn't match attachment 85275 [details] exactly.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI
Comment 6 QA Administrators 2016-09-20 09:32:46 UTC Comment hidden (obsolete)
Comment 7 Regina Henschel 2017-10-25 23:45:22 UTC
The text is still shifted for the two circles in the center.
Tested in Version: 6.0.0.0.alpha1+
Build ID: dc2d133e7953f08f73ef9cd0b40786764b0e2035
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-22_01:16:45
Locale: de-DE (de_DE); Calc: group
Comment 8 Xisco Faulí 2018-04-20 10:18:34 UTC
No longer reproduced in

Version: 6.1.0.0.alpha0+
Build ID: ffa6c70deb054c0dff4aab5a6ba5a03d0225d32d
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Closing as RESOLVED WORKSFORME

[Improvement found by office-interoperability-tools]